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About This Manual

Subject

Audience

Online Help

This manual provides information you need to start using PowerBuilder:

¢ Part One describes how to start PowerBuilder, use online Help, and
start the code examples

¢ Part Two is a tutorial in which you build your first PowerBuilder
application

This manual is for use by anyone who will be building applications using
PowerBuilder.

When you have a question about using PowerBuilder, you can access its
extensive online Help system. By accessing Help you can see:

¢ Procedures for accomplishing tasks in PowerBuilder
¢ Reference information about PowerBuilder topics or components

¢ Context-sensitive information about PowerBuilder functions or
reserved words in scripts

&> For more information on getting Help in PowerBuilder, see Part One,
"Welcome to PowerBuilder."



About This Manual

PowerBuilder
documentation

Topic

Manual

Description

Installation and
tutorial

Installation and
Deployment Guide

Getting Started

Provides instructions for installing
PowerBuilder; also includes setup
information you need to deploy
PowerBuilder applications on user
computers

Introduces you to PowerBuilder
and provides a tutorial you can step
through to learn the basics

The main
process

Building Applications

Guides you through the process of
using PowerBuilder to develop and
maintain applications (highlights:
project planning, basic and
advanced techniques)

Using the basic
tools

User's Guide

Tells how to use the painters to
build objects in PowerBuilder

Programmer's
reference

PowerScript
Language

Objects and Controls

Function Reference

Quick Reference

Gives an overview of PowerScript;
also describes the language's data
types and statements, as well as
SQL statements that you can use in
PowerScript

Lists attributes, events, and related
functions for PowerBuilder objects
and controls

Describes the PowerScript
functions and the DataWindow
painter functions; also describes
filters, validation rules, display
formats, text patterns, and
DataWindow attributes

Lists PowerScript functions and
DataWindow painter functions by
category, showing syntax for each;
also lists standard and enumerated
data types




About This Manual

Topic

Manual

Description

Communicating
with a database

Connecting to Your
Database

Tells how to connect to a database
from PowerBuilder (or InfoMaker);
tells how to set up, define, and
manage connections to ODBC data
sources and Powersoft database
interfaces

Watcom SQL Describes the Watcom SQL
database and how to use it with
PowerBuilder (or InfoMaker)
Advanced Application Library Describes the PowerBuilder
Developer Application Library, a collection of
Toolkit PowerBuilder objects that enable
you to accelerate the process of
building applications
Advanced Describes the Advanced
PowerBuilder PowerBuilder Utilities, a series of
Utilities tools that extend the PowerBuilder
development environment
PowerBuilder Library | Describes the windows,
for NetWare User's DataWindows, and functions used
Guide when developing applications with
the PowerBuilder Library for
NetWare
PowerBuilder Library | Describes the windows, user
for Pen Computing objects, and functions used when
User's Guide developing pen-based applications
with the PowerBuilder Library for
Pen Computing
Working with Version Control Tells how to use third-party
version control Interfaces version control systems to manage
systems PowerBuilder objects

Xi



About This Manual

Xii

Topic Manual Description
Working with PowerBuilder Library | Tells how to use the PowerBuilder
groupware for Lotus Notes User's | Library for Lotus Notes to develop
Guide PowerBuilder applications that
access Lotus Notes databases and
provide mail services through the
Vendor Independent Messaging
(VIM) protocol
PowerBuilder Library | Describes the objects in the
for Lotus Notes libraries provided with the
Reference PowerBuilder Library for Lotus
Notes
Working with C++ Class Builder Tells how to use the C++ Class
C/C++ Builder to define C++ classes,
compile them, store them in DLLs,
and then execute their methods
from PowerBuilder applications
Supporting Building InfoMaker Tells how to use PowerBuilder to
InfoMaker Styles and Actions build InfoMaker form styles, which

include layouts for displaying data
and actions for processing data



PART ONE

WELCOME TO POWERBUILDER

PowerBuilder is a graphic PC-based client/server application development
environment. Using PowerBuilder, you can develop object-based windows
database applications without coding in C or C++.

This part provides the information you need to get up and running. It
describes:

¢ Starting PowerBuilder
¢ Using online Help

¢ Using the code examples



Starting PowerBuilder

Starting PowerBuilder

Before you start PowerBuilder, read the installation notes for this release to
note any last-minute items.

< To start PowerBuilder:

¢ Double-click the PowerBuilder icon in the appropriate Windows
Program Manager group. The PowerBuilder initial screen displays. If
you installed the code examples, exampl40 (the code examples
application name) displays in the title bar.

=
I

" PowerBuilder - exampl40
File Help

You are now ready to use PowerBuilder to build an application.

For databases other than Watcom SQL
If you want to connect to a database other than Watcom SQL, see the
discussion on changing the database in Connecting to Your Database.
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Starting PowerBuilder from the command line

You can start PowerBuilder from the command line or the Program
Manager and optionally open one of the following painters (or the File

editor):
Application painter Menu painter
Database painter Query painter
Data Pipeline painter Report painter
DataWindow painter Structure painter
Debug painter User Object painter
Function painter Window painter

Library painter

To do so, use the following syntax:

{win} directon\pb040.exe { /P paintername}

The use of win is required when you start PowerBuilder from the command

line.

Switch

Description

/P

Parameter

Used with the painter name to identify the painter to access

Description

directory

paintername

The fully qualified name of the directory containing
PowerBuilder.

The name of the painter you want to open. The default is the
window that displays when you begin a new PowerBuilder
session. To open the File editor, set paintername to DO or
DOSEditor.

The painter name must uniquely identify the painter. You do not
have to enter the entire name. For example, you can enter W to
open the Window painter and dataw to open the DataWindow
painter. If you enter the full name, omit any spaces in the name
(enter UserObject and DataPipeline).



Starting PowerBuilder

Examples Enter this command at the command line to start PowerBuilder and open
the Window painter:

win pb4\pb040.exe /P w

Enter this command in the Windows Program Manager Run dialog box to
start PowerBuilder and open the DataWindow painter:

pb4\pb040.exe /P dataw
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Using online Help

PowerBuilder has extensive online Help. It uses the Microsoft Windows
Help facility.

Online Help supplements the information in the PowerBuilder manuals
and provides step-by-step directions for using the painters and all the
PowerBuilder features.

< To display context-sensitive Help for a dialog box:
¢ Click the Help button in a dialog box.

PowerBuilder displays information about the dialog box. From there
you can move to other topics.

< To display the main PowerBuilder online Help window:

¢ Click the Help button on the PowerBar.
or
Select Help>Help Index from the menu bar.
or
Press F1.

PowerBuilder displays the PowerBuilder Help contents window. From
there you can move to other topics.

< To search for a topic within Help:
¢ Select Help> Search for Help on from the menu bar.

PowerBuilder displays the Search dialog box. You use this dialog box
to type the item for which you want help and to select the appropriate
help topic.



Using online Help

< To access online Help for a function or keyword in a script:

Script - ;:Tick;”ﬁgr pb_new ]

Select the
function call or
PowerScript
keyword and
press SHIFT+F1

Description

Inserts a row in a DataWWindow. If any columns have default values, the row is initialized with
these values hefore it is displayed.

Applies to

DataWindow controls and child Datawindows

| Syntax
datawindownarae. InsertRow ( row )

Parameter Description

datawindowname
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Using the code examples

The PowerBuilder 4.0 code examples demonstrate the features of
PowerBuilder. The code examples use the Powersoft Demo DB database. If
you did not install the Powersoft Demo DB database, you will not be able
to run all the code examples.

Use the sample applications too

In addition to the code examples discussed here, PowerBuilder also
includes a number of sample applications. By using and reviewing these
applications, you can learn many useful concepts and techniques.

J

L

*,

» To start the code examples:
1 Make sure the EXAMPLAOQ application is the current application.
2

Click the Run button in the PowerBar.

The PowerBuilder 4.0 Code Examples window displays:

Aftribute Expressions

gCance! Retrieval & Printing

~ Column Text Value vs. ltem Value

Computed Fields in Aftribute Expr.

;Conyd«tiunal Bitmaps‘ )

Copy, Move, Discard Rows

his example will use the Dsta Pipeline to: his uses the Data Pipeline Object. The object is
11) Copy a table structure and dsta reated as & user object that is inherited from the
112) Copy a table structure, no data ystems Pipeline object. Once the object is crested,
7 XecLt i ast created or dynamically created Data Pipeline may

_employee_transaction: DataWindow Object
_open_help() {d_pipe_deptlist. DataWindow Object
er event ) p_pipe_wmeter: usercbject

From this main window, you can do many things:
¢ Scroll through the list of code examples.

¢ Run a code example.



Using the code examples

¢ Display online Help to get more information on using the code
examples.

Display a report showing detail information for the example.

.

¢ Restrict example display by status.
¢ Restrict example display by topic.
L4

Restrict example display by event, function, or object.

Examining the scripts and objects behind each example

To get the most out of the PowerBuilder code examples, you should
examine each example's scripts, functions, and objects (such as windows
and DataWindows). Part Two, "PowerBuilder Tutorial," will show you
how to use PowerBuilder painters to display windows, DataWindows,
and menus.

< To scroll through the list of code examples:

¢ Click on a line in the Example list.
or
Scroll using PAGE UP, PAGE DOWN, UP ARROW, and DOWN ARROW.

‘Datawindows { Add-Only DataWindow

g;‘-\ﬂribme Expressions

EXample IISt Cancel Retrieval & Printing

i’Column Text Value vs. ltem Value

Computed Fields in Aftribute Expr.

/ Conditional Bitmaps

Rows

The information in the bottom half of the window updates as you
scroll. It includes:

Example description

Techniques demonstrated by the example
Window name

PowerScript functions used in the example

Events and user-defined functions used in the example

* & & o o o

Objects used by the example
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+ To run a code example:

¢ Double-click an example in the list.
or
Click Run Example.

The selected application executes.

From within most examples, you can display additional information
via online help.

< To display online help for the code examples:
¢ Click Help.

The Help dialog box displays.

| Selecting an example

ach example is grouped under the topic that it relates to. In
ome cases, an example may appear in more than one topic. £

ach example also has a status. The statuses are:

4.0-The example contains 4.0 features

New - The example is new.
nhanced - The example has appeared in previous versions |
t PowerBuilder, but has now been enhanced
nchanged - The example has not been changed from the
revious version of PowerBuilder.

| { The status of the example is represented by icons to the right ¢
_jofthe example name. ltis possible that some examples may |
ave maore than one status. ex - All exarnples that are both

< To display a report showing detail information for a code
example:

¢ From the main window, select an example and click Show Detail.
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A detail report displays. You can zoom and print the report.

Detail Report for_Attribute Expressions E;;nple

Window Name ___ Category Ezample

Fagetof1
N
Yersion lew for releas Enhanced

w protected columns DataWindows Attribute Expr

Description

essions 40 &d

Teohnique

Shows howw to uze attribute expre: for ior objects in 3 DataWindow.
The DataWindos h 2 retrioval argument of
region. Only rows with the region name d can be modified
background if they are protected. A picture of 3 disk will 3ppest to the
1oft of cach row that will be updated in the database when the Update

Columng will bave 5 white background if they can be modified, and 3 grey

' the protect, background calor, and
For the column attributes reference the
retricval srqument o that only rows with the region name specificd in the
retrieval argument can be modificd. The IzRowNew function iz called in the
to specify that columns on new ro
 called from the visible attribute

i
button iz prezsed. of the picture ob|cct to show 3 picture of the disk when 3 row has been

[Object: d_region_zales
OropDownDataWindows
d_dddw_customers
d_dddw_fin_code
4_dddw_salez_reps
Object: w_protected_columns

DataWindows & Uzer Objects
Declured in control dw_1

d_region_zales DataWindow Object

Events Object Referenced
cloze

dbeancel
deleterow

Type of Object Referenced

cb_clozeiclicked event function
function
function
Function
function
function
t global function

cb_deleterclicked event
zetfacuz
triggererent
chzsname
i_open_hel

<b_helpiclicked event

< To restrict example display by status:

¢  Click the appropriate radio button in the Show box.

< To restrict example display by topic:
1  Click the down arrow in the Topics dropdown listbox.

A list of topics displays.

All Topics

All Topics
Data Pipeline
Dataitvindows
DDE

Drag + Drop
Dynarnic Dataindoves
Ermbedded SGL
Functions - External
Functions - PowerScript
Functions - User
Graphs
Inheritance
Mail Enabiling

10
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Use the bottom
half of the
window to
restrict display
by event,
function, or
object

% T
1

Click the topic you want to use to restrict display. You can also select
multiple topics (using SHIFT+click for two or more topics in sequence
and CTRL+click for two or more topics out of sequence).

The main window displays examples for the selected topics only.

o restrict example display by event, function, or object:

Click the Search button.

The bottom half of the window now contains a series of dropdown
listboxes that you can use to show only those examples that
demonstrate a particular event, PowerScript function, user-defined
function, or object.

PowerBuilder 4.0 Ex

ttribute Expressions

ancel Retrieval & Printing

olumn Text Value vs. Item Value

omputed Fields in Attribute Expr.

onditiungl Bitmaps

opy, Move, Discard Rows

Click the appropriate radio button to indicate whether to search for
events, PowerScript functions, user-defined functions, or objects.

This example searches for PowerScript functions. The title of the left-
hand column changes to reflect your selection.

1
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3 Click the down arrow in the PowerScript Functions dropdown listbox.

A list displays naming all PowerScript functions used in the code
examples.

accepttext
action
Alactivate
fadddata
jadddisk
fadditem
jaddseries
arrangesheets

4 Click on the function you want.

5  Optionally enter additional items to search on. Note the following:

¢

If you make multiple selections, examples using any of the
selected items are displayed

You can only select items of the type specified in the Search On
box (events, functions, user-defined functions, or objects)

6  Click the Perform Search button.

12
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The main window redisplays showing all examples that use the
selected PowerScript function. The examples also display a
magnifying glass icon to indicate that a search result set is active.

PowerBuilder 4.0 Examples 5 @

tem Status & Updating

Nested Reports

| Presentation Styles

Referencing Retrieval Arguments

| This example shows how to restrict modifications to a with PowerBuilder 4.0, the protect attribute for a
DstaWindow so that it only allows new rows to be DataWindow column can be set on or off based onthe | P
added, and disallows any changes to the original data. expression that is specified for the column. (To

1 specify an expression for the protect attribute, click the

i
lose() Datavwindow Object
{ fdbcancel() ¢ d_products_price: DataWindow Object

deleterow() / ~{d_sales_order_ttems: Datawindow Object
nsertrow() Fetrieveend event

13






PART TWO

POWERBUILDER TUTORIAL

The PowerBuilder tutorial is a series of 13 lessons in which you build a
complete Master/Detail database application. The window that displays
when you run the finished application looks like this.

Maintain Employees

File Employee Help

The top half of the window contains a list of employees with a pointer to a
single employee; the bottom half of the window displays extra detail for the
current employee.

15



What you will do

What you will do

Lesson 1 You will begin by using the PowerBuilder Application painter to create the
application object and associate an icon with the application.

Lessons 2 and 3 Then you will use the Database painter to create a database and a new
table, which contains employee data.

Lessons 4 and 5 Next you will create a window for the application with a single
PictureButton.

Lessons 6 You will then create one DataWindow to list employees and another one to
through 9 list detail information for a selected employee. You use these to maintain
your table.

Maintain Employees

16
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Lesson 10 Then you will add more PictureButtons to enhance the window and scripts
to allow users to insert and delete data and update the database.

Maintain Employees

Lesson 11 Next you will build a menu.

?; Maintain Employees

.E.)ile Employee Help

Save Ctrl+S

Print Detail Ctrl+P
Printer Setup

Alt+F4

Lesson 12 To see an example of inheritance, you will use this window to create
another one.

Lesson 13 Finally, to complete the tutorial, you will create an EXE file that you or a
user can run from Windows.

How long it will take

You can do the entire tutorial in one sitting in about four to five hours. Or
you can stop after any lesson and continue at another time.

17



What you will do

What you will learn
You will learn basic PowerBuilder techniques and concepts, including:

¢ How to use the Database painter to perform database definition,
extended attribute definition, and data manipulation

¢ How to use the Application painter to define an application object and
application-level scripts

¢ How to use the Window painter to create PictureButton controls,
DataWindow controls, window-level scripts, and control-level scripts

¢ How to use the DataWindow painter to define selection, grouping, and
display options

¢ How to use the PowerScript painter to define scripts for applications,
windows, window controls, and menus

¢ How to use the Menu painter to define menus, menu items,
accelerators, and shortcut keys

After you finish the tutorial, read the Appendix to review the tutor_pb
application, its components, and the events in which you coded
PowerScript statements.

This tutorial will not make you an expert in PowerBuilder. Only
experience building real-world applications can do that. It will, however,
give you hands-on experience and provide a foundation for continued
growth.

& After you finish this tutorial you should continue learning about
PowerBuilder by reading the Building Applications manual.
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Part Two PowerBuilder Tutorial

Setting up

Before you start the tutorial, make sure that the files you need for the
tutorial are on your hard disk, preferably in the same directory as
PowerBuilder.

The tutorial lessons use the following files:

EMPTUT.SQL SQL statements to provide data for a table
TUTOR_PB.HLP Online help file

TUTORIAL.ICO An icon

TUTDEL.BMP A bitmap

TUTEXIT.BMP A bitmap

TUTNEW.BMP A bitmap

TUTSAVE.BMP A bitmap

When you install PowerBuilder, these files are installed in the
PowerBuilder directory. When you have finished with the tutorial you can
delete them if you want.
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LESSON 1

Creating the Application Object

The first step in building a PowerBuilder application is to create an
application object. You are always developing within the scope of an
application object. In this lesson you will:

L4

L4

*

Create the tutorial application object
Specify the library that will hold the application object
Control PowerBuilder toolbars

Assign an icon to the application

How long will this lesson take?
About 15 minutes.
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Create and save the application object

Create and save the application object

22

Where you are

Lesson 1 Creating the Application Object
= Create and save the application object

Control the toolbars

Specify an icon for the application

Now you will create an application object for an Employee Maintenance
application. You will not put everything in it now. You will add more to
the application object later in the tutorial.

1  Start PowerBuilder, as described in Part One.

¢ If you have never worked with an application object and did
not install the sample application The Select Application
Library dialog box displays.

 [PB Libraries (-

PowerBuilder requires an application. If PowerBuilder cannot
access an Application object you must create one now.

2 Click Cancel.
3  Click New.

The Select New Application dialog box displays. Proceed with
step 4.



Lesson 1 Creating the Application Object

The PowerBar
accesses painters

¢

If you have previously worked with an application object The
initial window displays. It includes a toolbar called the PowerBar
at the top of the window. This toolbar accesses all of the major
PowerBuilder painters.

V R PowerBuilder - exampl40 B

Your toolbar may not show text or may be positioned in some
other area of the window. In a few minutes you will learn how to
control the display of toolbars. For now, don't worry if your screen
does not match the picture.

Click the Application painter button in the PowerBar.

Puwerﬂm;’t-exampldl]

Application painter
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Create and save the application object

The current application object opens and displays in the workspace.

Obiject name: exampld0 Last modified: 11/2/94 11:068:19
Library name: :\pbd\pbexamte,pbl Size in bytes 5164

Comments: PowerBuilder 4.0 Examples application Checked out by:
object

3  Select File>New from the menu bar.

The Select New Application Library dialog box displays.

Select New Application Library

,! PB Libraries (*.pbl) :;

About PowerBuilder libraries

The .PBL extension stands for PowerBuilder library and is
pronounced "pibble." All PowerBuilder objects (applications,
windows, DataWindows, menus, and user-defined functions and
objects) are stored in PowerBuilder libraries.
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Lesson 1  Creating the Application Object

4 Type tutor_pb.pbl in the File Name box.

5 Click OK.
The Save Application dialog box displays.

6  Type tutor_pbin the Applications box.
Press the TAB key twice to move to the Comments box.
Type This is the PowerBuilder tutorial application.

This associates a descriptive comment with the application object. The
comment you add here displays in the Library painter and helps to
identify objects. Comments are optional.

7 Click OK.
The Application dialog box displays.

Application

Would you like PowerBuilder to
generate an Application template?

8 Click No.
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Create and save the application object

PowerBuilder creates a library named tutor_pb.pbl and creates and
saves the application object named tutor_pb in the library. The
Application painter workspace displays.

Application - tutor_pb

E Obiect name: tutar_pb Last modified: 11/3/94 12:55:24
i Library name: c:\pb4itutor_pb.pbl Size in bytes: 1503
I Comments: This is the PowerBuilder tutorial application  Checked out by:

At this point, the tutor_pb application is your current application.

Each time you start up, PowerBuilder opens the current application.
Whenever you want, you can change the current application in the
Application painter.
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Lesson 1 Creating the Application Object

Control the toolbars

Where you are
Lesson 1 _Creating the Application Object
Create and save the application object
= Control the toolbars
Specify an icon for the application

PowerBuilder has four toolbars: the PowerBar, the PainterBar, the
StyleBar, and the ColorBar. You can control whether individual toolbars
display and where they display. You can also choose whether to display
text in the toolbars.

1 Move the pointer to any one of the buttons on the PainterBar and pause.
Do not click.

PowerBuilder displays a PowerTip identifying the button's function.

PowerTips are displayed whenever the pointer pauses over a toolbar
button.

PowerTips don't display when toolbars show text

If your toolbar buttons show text, PowerBuilder suppresses the
display of PowerTips. The following steps tell you how to control
text display.
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Control the toolbars

2

PainterBar
buttons

Popup menu

28

Move the pointer to any one of the buttons on the PainterBar and click
the right mouse button.

The popup menu for the toolbars displays.

buw;}Bu il.d-;i'tuloLEH

Applic; ::uwr_;ﬁ

PowerBar
“ +/ PainterBar

. Top

. Right
| Bottom
Floating

Last modified:

tutor_pb 11/3/9412:56:24
c:\pb4\tutor_pb.pbl Size in bytes: 1503

This is the PowerBuilder tutorial application  Checked out by:

About the popup menu

Throughout PowerBuilder, popup menus provide a fast way to do
things. The right mouse button accesses the popup menu. The menu
changes depending on the painter you are in and where you are in
the workspace when you click the right mouse button.

Click Floating in the popup menu.

The PainterBar changes to a floating toolbar.

Move the pointer to an empty area within the floating toolbar and drag
the floating toolbar to a convenient position.

How to drag the toolbar

Press and hold the left mouse button. While pressing the button,
move the mouse (an outline displays to show the current location of
the toolbar).

When the toolbar is where you want it, release the mouse button.




Lesson 1 Creating the Application Object

tutor_pb Last modified: 11/3/9412:55:24
c:\pbdtutor_pb.pbl Size in bytes: 1503

This is the PowerBuilder tutorial application  Checked out by:

You can put toolbars in many different locations: left, top, right,
bottom, and floating.

Some painters have so many buttons that you need to use the floating
toolbar to display all buttons. Or you may be able to display all the
buttons if you turn off the display of text.

You can also customize toolbars. You can remove buttons, add, or
change the order of the buttons.
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Control the toolbars

30

5

6

Drag the floating toolbar toward the left side of the workspace.
Release the mouse button when the toolbar becomes a vertical bar.

"~ PowerBuilder - tutor_pb BB

Obiject name: tutor_pb Last modified: 11/3/94 12.55:24
Library name: c:\pbd\tutor_pb.pbl Size in bytes: 1503
Checked out by:

Comments: This is the PowerBuilder tutorial application

Select Window>Toolbars from the menu bar.

The Toolbars dialog box displays. The position of the currently
selected toolbar shows as the selected radio button.

ﬁ Toolbars ]

Deselect the Show PowerTips checkbox.
Select the Show Text checkbox.

PowerBar
PainterBar




Lesson 1 Creating the Application Object

8 Click PainterBar.
Click Floating.

Toolbars

9  Click Done.
This makes the PainterBar floating.
Now you know several ways to move the toolbars.

For the rest of this tutorial, you should move the toolbars where you like to
have them. Your screen may not match exactly the pictures in this book,
depending on where and how you display toolbars. For example, the rest of
the tutorial shows toolbar buttons with text displayed; you may decide to
work with no text, displaying PowerTips as the need arises.
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Specify an icon for the application

Specify an icon for the application

Where you are

Lesson 1 Creating the Application Object
Create and save the application object
Control the toolbars

= Specify an icon for the application

The icon you specify displays in the Windows workspace when you
minimize your application while executing it.

PowerBuilder includes the icon automatically when you create an
application EXE file.

1

2

32

Click the /con button in the PainterBar.

The Select Icon dialog box lists all available icons.

Select tutorial.ico.

The Tutorial icon displays in the dialog box.

g Select lcon

\pb4A\TUTORIAL.ICO

| orgchart.ico
tutorial.ico

Click OK.

You return to the Application painter workspace.

Select File>Save from the menu bar.

This saves the updated application object.

Click the Return button on the PainterBar.

You return to the initial window.




LESSON 2

Creating the Table

Tables are the way relational databases organize information. In many
organizations, database specialists maintain the database. If this is true in
your organization, you may not be permitted to create and maintain tables
within the database. However, to take full advantage of PowerBuilder, you
need to know how to work with database tables.

PowerBuilder is installed with a single-user Watcom SQL database. You
can create and work with tables in the Watcom SQL database.

In this lesson you will:
¢ Create a new database for this tutorial

¢ Create a new table for employees

How long will this lesson take?
About 15 minutes.
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Open the Database painter

Open the Database painter

34

Where you are

Lesson 2 Creating the Table
= Open the Database painter

Create a new database

Create the table

1

2

Click the Database painter button in the PowerBar.

Database painter

The Select Tables dialog box displays. It lists the tables in the database
you are currently connected to and has a New button for creating new
tables.

Because you are going to create a new database before you create your
table, you will cancel out of this dialog box for now.

Select Tables

tact

| |customer
| i department
 employee

examples
‘1examples_categories_list
‘{examples_groups
fin_code
ifin_data

ole

printer

product

Click Cancel.




Lesson 2 Creating the Table

The Select Tables dialog box closes. You are in the Database painter.
The workspace is blank. Notice that the workspace title bar identifies
the database you are currently connected to.

Database - Powersoft Demo DB

——
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Create a new database

Create a new database

Where you are

Lesson 2 Creating the Table

Open the Database painter
= Create a new database

Create the table

For this tutorial, you will create a new database. When you are finished
with the tutorial, you can easily delete the database.

1 Select File>Create Database from the menu bar.

The Create Local Database dialog box displays.

2 Click Browse.

The Create Local Database dialog box displays.
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Lesson 2 Creating the Table

Database file
name

3 Type tutor_pb.db in the File Name box.

If you want to change directory or drive for storing the database file,
you can use the Directories or Drives boxes.

Current directory

Creatr L33! Natabase

Current drive

Click OK.

PowerBuilder redisplays the original Create Local Database dialog
box.

Click OK.

PowerBuilder creates a local Watcom SQL database named Tutor_pb
in the current directory and connects to the Tutor_pb database.

== T il der - tutor_pb
File Objects Options Window

Database - Tutor P!

PowerBuilder also adds database information to the Windows
ODBC.INI file and creates and adds a database profile to your
PowerBuilder preferences file (PB.INI). This will allow you to connect
to the database easily in the future.
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Create the table

Create the table

38

Where you are
Lesson 2 Creating the Table
Open the Database painter
Create a new database

= Create the table

To create the table, you use the Create Table dialog box. In this dialog box,
you:

¢ Name the table and define its columns
¢ Define the primary key
¢ Request table creation

When you finish entering information, the Create Table dialog box will
look like this.

Create Table

emp_id

3 emp_dept_id

emp_name

emp_status

emp_salary

When you click the Create button in this dialog box, PowerBuilder
generates the SQL statements required to create the table. Then
PowerBuilder submits the statements to the Watcom SQL database
management system (DBMS), which creates the table.



Lesson 2 Creating the Table

Display the Create Table dialog box

1  Click the New button on the PainterBar.

The Create Table dialog box displays. In the top part of this dialog
box, you define the columns in the table. In the bottom part of the
dialog box, you define extended attributes.

The dialog box also has a Help button, which displays Help for the
dialog box.

Help button

2  Click the Help button.

Help for the Create Table dialog box displays. The online Help system
is comprehensive. As you do the tutorial, use the Help button
whenever you want to find out more about a dialog box.

3 Double-click the Control-menu box to close the Help window.

(ED
t~Ffe Edit Bookmark Hel,

Double-click here
fo exit help

The Help window closes and you return to the Create Table dialog
box.
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Create the table

Name the table

1 Click in the Table box to reposition the insertion point.
Type emp_tutorial

“Create Table

2 PressTaB.

The insertion point moves to the Name box for the first column.



Lesson 2 Creating the Table

Define the columns in the table

1 Type emp_id and press TAB.

The insertion point moves to the Type box. The default data type
(char) is highlighted. The data type for the emp_id column needs to be
integer.

About default data types
Char is the default data type for the first column. The default data
type for subsequent columns is the type of the previous column.

2 Click the down arrow to the right of the word char and select integer from
the menu of available data types (scroll the list if necessary).

This changes the data type for emp_id to integer.

Another way to select a data type
You can also select a data type by typing the first letter of the data
type in the Type column. For example, to select integer, type .

3 Press TAB twice.

This moves you past the setting of No for the column labeled Null. No
means you do not want to allow the column you are defining to be
empty (to have a Null value). Since you always want a value for
emp_id, you will leave the value No.

The arrow pointer now points to the line for the next column.

4  Type emp_dept id

The Type and Null values default to the values in the previous column
(integer and No). These are correct, so you can leave them unchanged.

1



Create the table

42

5  Press the DOWN ARROW key.

The arrow pointer moves down so you can define the next column.

s Nawe
emp_id o

; emp_dept_id

6  Finish entering information about the table columns.

The following table shows all the values needed to define the columns
for the emp_tutorial table. You have already entered values for the first
two columns (emp_id and emp_dept_id).

Name Type Width Dec Null
emp_id integer No
emp_dept_id integer No
emp_name char 30 No
emp_status char 1 No
emp_salary numeric 9 2 No

Now you have provided the information required to define the emp_tutorial
table. Next you will define a primary key for the table.



Lesson 2 Creating the Table

Define the primary key

To use a database table in a DataWindow, the table must have a primary
key. The primary key uniquely identifies each row. In the emp_tutorial
table, emp_id is the unique identifier of each row of data.

1 Click the Primary Key button in the lower-right side of the Create Table
window.

The Primary Key Definition dialog box displays.

mary Key Definition - emp_tutorial

emp_tutorial

You use this window to pick one or more columns as the primary key.

2 Click emp_idin the list of columns.

Emp_id displays in the Key Columns box.

Primary Key Definition - emp_tutorial

mp_salary
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Create the table

3 Click OK.

This defines emp_id as the primary key for your table. When you
request table creation, PowerBuilder will include the SQL statement
required to define a primary key.
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Lesson 2 Creating the Table

Request table creation

1 Make sure your Create Table dialog box looks like this.
Click the Create button.

} emp_dept_id

emp_name

i
;yeymp—slalus
|

emp_salary

PowerBuilder generates the SQL statements required to create your
new table and sends them to the Watcom SQL DBMS.
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Create the table

The DBMS creates the new table. The Database painter displays a
representation of the new table in the workspace. The symbol coming
from emp_id indicates that emp_id is the primary key for the table.

2 Move the pointer to the table name (emp_tutorial) and click the right
mouse button.

Right-click
the table name

Definition...
Comment...
Font...

New »|
Primary Key...

Drop Table

Data Manipulation...
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Lesson 2 Creating the Table

3 Click Close.

The Database painter closes the table.

Removed from the workspace only
When you close a table, the Database painter just removes it from
the workspace display. It does not delete it.

4  Click the Open button on the PainterBar.

The Select Tables dialog box displays.

5 Double-click emp_tutorial.

femp_ tutonal

The Database painter reopens the table.

PowerBuilder - !umrj)_hw

47



Create the table

Now you know how to open and close tables in the Database painter. In the
next lesson you will define extended attribute information and data for the
columns in the emp_tutorial table.

Keep going

Because Lesson 3 builds upon what you've just learned about the
Database painter, it's best to go directly to Lesson 3. If you must stop, be
sure to review the techniques and concepts learned in Lesson 2 before

beginning Lesson 3.
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LESSON 3

Adding Extended Attribute Information
and Data

Once you have created a table, you can provide information about its data.
By specifying extended attribute information, you can determine how data
is displayed and validated. Then you can add data to the table.

In this lesson you will:
¢ Add extended attribute information for the table
¢ Add data to the table using a SQL file

¢ Review the results of your work

How long will this lesson take?
About 30 minutes.
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Add extended attribute information

Add extended attribute information

Selected column

Extended attributes
for the selected ——
column

50

Where you are

Lesson 3 Adding Extended Attribute Information and Data
= Add extended attribute information

Add data to the table

Examine the table

Add a new row

PowerBuilder stores extended attribute information in the database in a
collection of system tables called the repository. PowerBuilder uses this
information in a DataWindow to determine how data is displayed and how
user-entered data is validated. Extended attributes include:

¢ Headers and labels for columns
¢ Initial values for columns

¢ Validation rules

¢ Display formats

When you create a DataWindow, PowerBuilder uses the extended attribute
information as the default values for the DataWindow. In the DataWindow
painter, you can override these values.

When you are working in a multiuser environment, defining this
information in the Database painter offers two important advantages: time
savings and consistency. Anytime anyone uses the data, they can access the
repository information.

iemp_id 1 i
; emp_dept_id i

emp_name

emp_status

emp_salary




Lesson 3 Adding Extended Attribute Information and Data

This table summarizes how you will extend the column definitions of the
emp_tutorial table columns.

Column name | What you will do to extend its definition

emp_id Modify header and label information
emp_dept_id Modify header and label information
emp_name Modify header and label information
emp_status Modify header and label information

Define an initial value

emp_salary Modify header and label information
Define a validation rule
Define a display format

You specify extended attribute information in the bottom of the
Create/Alter Table dialog box.
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Add extended attribute information

Define headers and labels for columns
1 Move the pointer to the table name (emp_tutorial) and right-click.

Right-click
emp_tutorial

4 Definition...
Comment...

Primary Key...

Drop Table
Data Manipulation...

The popup menu for the table displays.

2 Click Definition.

The Alter Table dialog box displays with the arrow pointer identifying
the selected column emp_id.

Alter Table

i;}nlegel
ﬁchal
:iemp_:latus ;Fhar '

;Tp_:aialy 3 ?ﬁlmelic
%....__.MW
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Lesson 3 Adding Extended Attribute Information and Data

3

Highlight Emp Id in the Header box in the bottom of the dialog box.

This selects Emp Id, which is a default header created from the
column name.

Type Employee ID

Two-line headers
You can create two-line headers. To do this, press CTRL+ENTER at
the end of the first line and then type the second line.

Press TAB twice to move to the Label box.

Again, the default value is Emp Id and it is highlighted.

Type Employee ID:

7 Move the pointer to emp_dept_id in the Name box and click.

The arrow pointer identifying the selected column moves to
emp_dept_id.

emp_id

emp_dept_id

emp_name -
emp_status

3 emp_salal;g o
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Add extended attribute information

8  Finish entering header and label information for the emp_tutorial

columns.

The following table shows all Header and Label values for the
emp_tutorial table. You have already entered values for the first
column (emp_id).

Name Header Label
emp_id Employee ID Employee ID:
emp_dept_id | Department Department:
emp_name Name Name:
emp_status Status Status:
emp_salary Salary Salary:

9  Click the Alter button to process the changes.

PowerBuilder changes the header and label information in the
repository. You return to the Database painter workspace.

54
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Lesson 3 Adding Extended Attribute Information and Data

Define an initial value for emp_status

1 Move the pointer to the emp_status column and right-click.

Right-click
emp_status

Definition...
= Comment...
Display...
Edit Style...
Header...
Validation...

The popup menu for emp_status displays.

2  Click Definition.

The Alter Table dialog box displays with the arrow pointer at the
selected column emp_status.
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Add extended attribute information

3 Click the Initial box.

5  Click the Alter button to process the changes.

PowerBuilder changes the initial value information in the repository.
You return to the Database painter workspace.

Whenever you create a DataWindow that includes the emp_status column,
the default initial value for the column will be A (for Active).

In any DataWindow, you can change the initial value or even eliminate it.
You specify extended attribute information to provide default values for a
newly created DataWindow.
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Lesson 3 Adding Extended Attribute Information and Data

Define a validation rule for emp_salary

1 Move the pointer to the emp_salary column and right-click.

Right-click
emp_salary

Definition...
Comment...
Display...
Edit Style...
Header...
Validation...

The popup menu for emp_salary displays.

2  Click Validation.

The Column Validation for emp_salary dialog box displays. Use this
dialog box to assign a validation rule (and initial value) to a specific
column.

You use the Edit and New buttons to edit and create validation rules.
You will create a new one now.
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Add extended attribute information

3  Click the New button.

The Input Validation dialog box displays with the insertion point in
the Name box. This dialog box is for creating and maintaining
validation rules.

Input Validat

‘Item ~" + @emp_salary + '~ does not pass validation

4  Type ValidSalary in the Name box.

This assigns the name ValidSalary to the new validation rule.

5 PressTaB.

The insertion point advances to the Rule Definition box.

Specifying validation rules

You can specify rules by typing the entire rule on the keyboard or
clicking buttons in the dialog box. This example uses both
techniques.
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Lesson 3 Adding Extended Attribute Information and Data

It is pasted here

Click here

6 Click the @emp_salary button in the Paste box in the bottom-left corner

of the dialog box.

This pastes the @emp_salary placeholder into the Rule Definition box.

T, 4,

~" + @emp_salary + "' does not pass validation test.

bs( x ]
Niasc[s )
/ avg( #x for all )
itmap [ s )
eiling( x )

Click at the end of the pasted entry @emp_salary to position the insertion
point.
Type >5000

Your validation rule should look like this now:

| @em alaly)ﬁ(!ﬁ

Click OK.

If the expression is not correct, an error message displays. Correct the
error and click OK again.
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Add extended attribute information
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PowerBuilder adds the validation rule to the repository and redisplays
the Column Validation for emp_salary dialog box. The rule
ValidSalary is highlighted. You want to associate this rule with the
emp_salary column.

n Validation for -emp;salary

Click OK.
This associates the ValidSalary rule with the emp_salary column.

Now that you have the ValidSalary rule in the repository, you can use
it for other columns. Once defined, validation rules display in the list
of available rules.

You return to the Database painter workspace.

Database - Tutor Pb




Lesson 3 Adding Extended Attribute Information and Data

Define a display format for emp_salary

Right-click
emp_salary

Move the pointer to the emp_salary column and right-click.

Definition...
Comment...
Display...
Edit Style...
Header...
Validation...

The popup menu for emp_salary displays.

Click Display.

The Column Display Format for emp_salary dialog box displays. Use
this dialog box to assign a display format to a specific column.

Column Display Format for emp_salary

{#.480.00
| $8.810.00:($4.8110.00)

$i.#140.00:[RED]($#.#10.00)
#.HR0:($3.110)

You use the Edit and New buttons to edit and create display formats.

Click the New button.

The Display Format Definition dialog box displays with the insertion
point in the Name box. This dialog box is for creating and maintaining
display formats.
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Add extended attribute information

4  Type SalaryFormatin the Name box.

This assigns the name SalaryFormat to the new display format.

5 Press TAB to move to the Format box and type [currency]

mat Definition

SalaryFormat

The value [currency] uses the Windows default currency format to
display and print numbers.

6 Click in the Test Value box and type 25000

7  Click the Test button.

If the display format is correct and the [currency] format is set for
United States currency, the value $25,000.00 will display in the Result
display area.

For countries other than the United States

If you select a country other than the United States in the Windows
Control Panel, the value displays in the correct format for that
country.
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Lesson 3 Adding Extended Attribute Information and Data

8 Click OK.

This adds SalaryFormat to the repository and redisplays the Column
Display Format for emp_salary dialog box. SalaryFormat is
highlighted.

10.00%
a0 —
|

SalaryFormat

9 Type 0.7in the Display Width box.

This makes the emp_salary column display a little wider so that the
dollar sign isn't truncated.
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Add extended attribute information

10 Click OK.

This assigns SalaryFormat to the emp_salary column and returns you
to the Database painter workspace.

= Database :Nf”ulm Pb
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Lesson 3 Adding Extended Attribute Information and Data

Add data to the table

Where you are
Lesson 3 Adding Extended Attribute Information and Data
Add extended attribute information
= Add data to the table
Examine the table
Add a new row

In this section you will add employee data to your new table.

1  Click the Admin button on the PainterBar.

The Database Administration window displays.

m R I —“—“’MT:'DWBIBUIMCI tutor _pb - Em
Flle Edit Scan:h Objects Window Help |

Database Administration - ODBC.TUTOR_PB.dha

This window is a text editor in which you can enter, edit, and execute
SQL statements.

To save time, this tutorial provides a file of SQL INSERT statements.
You will import this file and execute the statements.
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Add data to the table

2

66

Select File>Import from the menu bar.

The File Import dialog box displays.

File Import

This dialog box displays a list of SQL files in the current directory.
(Your list may look different from this one.)

Double-click emptut.sql in the list of files.

If the emptut.sql file is not listed
Change to the directory in which you installed PowerBuilder.

PowerBuilder opens the file and copies its contents into the workspace.
The file contains the SQL INSERT statements required to add rows to
the emp_tutorial table.

Database Administration - ODBC.TUTOR_PB.dba -1~}
INSERT INTO emp_tutorial VALUES { 1191 , 480 , 'Bucceri, Matthew' ,
INSERT INTO emp_tutorial VALUES { 1250 , 188 , 'Diaz, Emilio' , 'A"
INSERT INTO emp_tutorial VALUES ( 1398 , 368 , ‘Litton, Jennifer' ,
INSERT INTO emp_tutorial UALUES ( 1446 , 280 , ‘Yeung, Caroline' , *
INSERT INTO emp_tutorial UALUES ( 1507 , 480 , 'Wetherby, Ruth' , ‘A
INSERT INTO emp_tutorial UALUES ( 1578 , 508 , ‘Rebeiro, Anthony’ ,
INSERT INTO emp_tutorial UALUES ( 1596 , 288 , ‘Pickett, Catherine’
INSERT INTO emp_tutorial UALUES ( 1667 , 408 , 'Morris, Mark ' , 'A°
INSERT INTO emp_tutorial VALUES ( 1615 , 588 , ‘Romero, Sheila' , 'A
INSERT INTO emp_tutorial UALUES ( 1643 , 4080 , ‘Lambert, Elizabeth®
INSERT INTO emp_tutorial VALUES ( 1658 , 588 , 'Lynch, Hichael' , 'R
INSERT INTO emp_tutorial VALUES ( 1684 , 480 , ‘Hildebrand, Janet' ,
INSERT INTO emp_tutorial UALUES ( 1748 , 468 , *Nielsen, Robert' , °*
INSERT INTO emp_tutorial UALUES ¢ 1751 , 488 , ‘Ahmed, Alex" , 'A°
INSERT INTO emp_tutorial UALUES ( 856 , 200 , 'Singer, Samuel' , 'A"
INSERT INTO emp_tutorial UALUES ( 1483 , 3688 , ‘Letiecq, John' , 'L’
INSERT INTO emp_tutorial UALUES ( 182 , 188 , 'Whitney, Fran' , A"
|

Click the Execute button in the PainterBar.

This sends the SQL INSERT statements to the Watcom SQL DBMS to
insert data into your new table.



Lesson 3 Adding Extended Attribute Information and Data

This happens quickly

The Watcom SQL DBMS processes the SQL INSERT statements quickly.
A message displays only if an error occurs. To confirm that the
rows were added to the database (and to see an example of an error
message), click the Execute button again. A duplicate key message
will display because the row was added the first time you clicked
Execute. The message box asks if you want to continue. Click the
No button.

Click the Return button in the PainterBar (not the Database Painter button
in the PowerBar).

The Save Changes dialog box displays, prompting you to save changes
to the emptut.sql file.

Click Noin response to the Save Changes dialog box.

If you do not see the Return button
Remember that you can change the position of the PainterBar (for
how, see "Control the toolbars" in Lesson 1).

This closes the Database Administration window and returns you to
the Database painter workspace.
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Examine the table

Examine the table

68

Where you are
Lesson 3 Adding Extended Attribute Information and Data
Add extended attribute information
Add data to the table
= Examine the table
Add a new row

You now have a complete table, with repository information and more than
seventy employees. You can use the PowerBuilder Data Manipulation
facility to display the data in your table and add, change, or delete the
TOWS.

The Data Manipulation window includes a DataWindow that PowerBuilder
creates using the columns in the selected table.

1 Make sure you are still in the Database painter and that the emp_tutorial
table is open.

F—

T




Lesson 3 Adding Extended Attribute Information and Data

Labels come
from the
repository

Select Objects>Data Manipulation from the menu bar and click
FreeForm.

The Data Manipulation window opens. PowerBuilder retrieves all your
employee data and displays as many employees as will fit in the
window. Your window may only display one employee at a time.

Notice that PowerBuilder uses the column labels from the extended
attribute entries you made earlier. Notice that the salary format is
currency as you specified in the extended attributes for the emp_salary
column. This happens because the Data Manipulation window is really
a DataWindow object.

Rows are not retrieved in any particular order

The employee that displays first is not necessarily the employee
with the lowest ID. Unless you specify an order, relational
databases do not retrieve rows in any particular order.

Click the Next and Prior buttons in the PainterBar to display the data for
other employees.

You can also use the scroll bar on the right of the window to scroll
through the data.

69



Add a new row

Add a new row

Where you are
Lesson 3 Adding Extended Attribute Information and Data
Add extended attribute information
Add data to the table
Examine the table
= Add a new row

Click the Insert button in the PainterBar.

This inserts a new row. The status field displays A, as you specified in
the extended attributes. To change the status, you enter a status in the
Status column.

Data Manipulation for emp_tutorial

Status has an initial
value of A as defined
in the repository

2  Enter data in the Employee ID, Department ID (use 200), and Name
columns.

3  Enter asalary that is less than 5000 in the Salary column (don't enter a
dollar sign or a comma) and press TAB.

This value fails the validation test that you specified in extended
attributes. PowerBuilder displays an error message.
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Lesson 3 Adding Extended Attribute Information and Data

Data Manipulation for emp_tutorial

Item '4999' does not pass validation test.

Handling errors in your program

You can use the ItemError DataWindow event in your program, to
trap this error and display your own error message. Or you can use
the DataWindow painter to override the validation rule's default
message.

&~ For information about trapping errors and overriding the
default message, see Building Applications in the PowerBuilder
documentation set.

Click the OK button in the error message box and enter a higher value for
salary.

Click the Updt DB button in the PainterBar (if you're using PowerTips, the
text is Save Changes).

This updates the database with the new row.

Changing and deleting data for an existing employee

You can also change and delete data for an existing employee. Be
sure to click the Updt DB button to update the database with the
changes.

Select File>Close from the menu bar to close the Data Manipulation
window.

If you have made additional changes without clicking the Updt DB
button, you are prompted to specify whether you want to update the
database with your changes.

Data Manipulation for emp_tutorial

9 Save changes back to database?

Cancel |

7



Add a new row
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7 Click Yesor No.

The Database painter workspace displays.

F'owerBuiId—f:-r” tutor_pb

Database - Tutor Pb

8 Select File>Close from the menu bar to close the Database painter.
The initial window displays.

You have created a new database table, provided extended attribute
information for its columns, and put data into it.



LESSON 4

Building the Window

Windows are the main interface between the user and PowerBuilder
applications. Windows can display information, request information from a
user, and respond to mouse or keyboard actions.

In this lesson you will:

¢ Build a window for your application

¢ Add a PictureButton to close the window
¢ Build a script for the PictureButton

¢ Build a script for the application

When you finish this lesson, your application window will have an Exit
PictureButton that works. It will look like this during execution.

How long will this lesson take?
About 20 minutes.
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Create a new empty window

Create a new empty window

Where you are
Lesson 4 Building the Window
= Create a new empty window
Add a PictureButton control
Display the attribute values
Add a script for the PictureButton control
Save the window
Add an application script
Run the application

1 Click the Window painter button in the PowerBar.

PowerBuilder - tutor_pb

Window painter

The Select Window dialog box opens.

Select Window

From this dialog box you can open an existing window and modify it,
create a new window, or inherit from an existing window to create a
new descendent window.
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Lesson 4 Building the Window

Click the New button.

The Window painter workspace opens. The gray rectangle represents
the window you are building.

‘PowerBuilder - tutor_pb
ile Edit Controls Design Declare Options Wi

Your background color may be different

If your window displays with a white background instead of a gray
background, the Default to 3D option has been disabled. When this
option is enabled, the Window painter's default environment
includes a gray background and 3D controls. To change this
setting, select Options> Default to 3D from the menu bar and re-
open the Window painter.
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Create a new empty window
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Make the window rectangle larger.

" To do this, move the pointer to the lower-right corner of the rectangle.

When it turns into a double-headed arrow, drag the arrow down and to
the right to enlarge the rectangle. Make it almost as large as the
Window painter workspace.




Lesson 4 Building the Window

Add a PictureButton control

Where you are
Lesson 4 Building the Window
Create a new empty window
% Add a PictureButton control
Display the attribute values
Add a script for the PictureButton control
Save the window
Add an application script
Run the application

The controls you can put in a window are pictured in the PainterBar and
listed in the Controls menu.

In this section you will put a PictureButton control in the window.

PictureButtons versus CommandButtons

This tutorial uses PictureButton controls, which display a button
containing a bitmap that you specify, instead of CommandButtons,
which simply display a button containing text. You could just as easily
use CommandButtons.

To help you get acquainted with the PowerBuilder development
environment, the bitmaps used for the tutorial's PictureButtons are
similar to those used by PowerBuilder PainterBars. In your applications
you should implement PictureButtons that have meaning to your
application's users.

1

Click the PictureButton button in the toolbar.
or
Select Controls > PictureButton from the menu bar.

Design Declare Options W
i—EoTmmanaoutton~ Picture |
I PictureButton ) GroupBox i

Ste UserQbject...
SingleLineEdit Graph
EditMask Line
MultiLineEdit Oval
ListBox Rectangle

RoundRectangle |
HScrollBar
¥YScrollBar
OLE 2.0

CheckBox

| RadioButton

| DataWindow

i DropDownListBox




Add a PictureButton control

Tip

If your display does not show all the buttons in the PainterBar, you
may prefer to make the PainterBar floating (select
Window>Toolbars from the menu bar). Alternatively, you can turn
off text and use PowerTips to remind you of each button's function.

2  Click where you want the button in the window.

A PictureButton displays at the selected location. Default text (none)
displays on the button. The small black boxes in the corners indicate
that this control is selected.

Window - (Untitled)

3 Select none in the text box at the top of the Window painter and press
DELETE.

This eliminates the text from the PictureButton.
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Lesson 4 Building the Window

Double-click the button.
The Select Picture dialog box displays.

Select Picture

| [baby2bmp

baby3.bmp

1 beach.bmp

| | blarmow.bmp
capb.bmp
capw.bmp
cascadel._bmp
cascade2 bmp

Scroll as needed and double-click the filename tutexit.bmp.

The Select Picture dialog box closes and the PictureButton dialog box
displays.

Select the Original Size checkbox.

PictureButton

Click OK.

The Window painter workspace displays.
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Add a PictureButton control

80

Adjust the location of the PictureButton.
Move it to the upper-right corner of the window.

¢ Move the pointer near the center of the PictureButton.
¢ Press and hold the left mouse button.
¢ Drag the PictureButton to a new location.
¢ Release the mouse button.
How to delete controls

If you add a control to the window and later decide you do not want it,
select the control and click the PainterBar's Clear button or press the
DELETE key. This deletes the control and its scripts.




Lesson 4 Building the Window

Display the attribute values

Where you are
Lesson 4 Building the Window
Create a new empty window
Add a PictureButton control
= Display the attribute values
Add a script for the PictureButton control
Save the window
Add an application script
Run the application

Every object and control has a style that determines how it looks. The style
comes from the values assigned to its attributes. You can display some
attributes of an object or control by double-clicking it.

¢ Move the pointer to the PictureButton control that you just created and
double-click.

The PictureButton dialog box opens.

This dialog box displays the values of some of the attributes of the
PictureButton control.
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Display the attribute values

Specify a name

PowerBuilder assigns the PictureButton the default name pb_1. The 1 is
highlighted, ready to change.

About default names for controls

PowerBuilder assigns each control a default name. The default name is
the prefix specified in Preferences (for example, pb_) and the lowest
number that will make the name unique.

It is not necessary to change the default name of a control. However,
changing the number portion of the default name makes your
application easier to understand.

1 Type exit

Exit replaces the highlighted 1 and the PictureButton control name
becomes pb_exit.

c:\pb4\tutexit.bmp

i Center 3

2 Click OK.

You return to the Window painter workspace.
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Lesson 4 Building the Window

Add a script for the PictureButton control

Where you are
Lesson 4 Building the Window
Create a new empty window
Add a PictureButton control
Display the attribute values
= Add a script for the PictureButton control
Save the window
Add an application script
Run the application

Next you will add a one-line script to this button's Clicked event. When the
user clicks on this PictureButton, PowerBuilder executes the Clicked event
script.

1 Move the pointer to the button and right-click.
The popup menu for the button displays.

— Script...

Change Disabled...
Change Enabled...
Drag and Drop »
Name...

Pointer...

Style »

Bring to Front
Send to Back
Clear
Duplicate
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Add a script for the PictureButton control

84

2

Click Script.
The PowerScript painter displays.

The PowerScript painter is a text editor. You can use the buttons in the
PainterBar to:

® & & 6 6 6 O O O o o o

Undo your last change

Cut selected text and place it in the clipboard
Copy selected text to the clipboard
Paste text from the clipboard

Clear selected text

Select All text

Comment out one or more selected lines
Uncomment one or more selected lines
Paint SQL statements

Paste a statement into your script
Browse object information

Return to the Window painter
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Build the script

Type this script:

close(parent)

Highlight parent.

Select Event . Paste Ob
1
BEE(barent)) ‘

Press SHIFT+F1.

PowerBuilder displays help for the reserved word Parent.

, ~ PowerBuilder Help - PBHLPOADHLP
e Edit Bookmark Options Hel,

The words PowerBuilder uses intemally are called reserved words and generally
cannot be used as identifiers. The exceptions are Parent, This, ParentWindow, and
Super. You can use these pronouns to make general references in scripts to objects
and contrals

See Also
Reserved werds

Parent, This, ParentWindow, and Super
Parent

ParentWindow
Super

Accessing context-sensitive Help
Select a function or reserved word and press SHIFT+F1.

Double-click the Control-menu box in the upper-left corner of the Help
window to close it.

or

Select File>Exit from the menu bar.
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Add a script for the PictureButton control

Compile the script

86

¢ Click the Return button.
or
Select File> Return from the menu bar.

Your script compiles and you return to the Window painter workspace.

Handling errors in scripts

When there is an error in a script, an error window displays at the
bottom of the PowerScript painter with the line number of the error
and the error message. To move to the line with the error, click the
error message. After you correct the error, click the Return button.




Lesson 4 Building the Window

Save the window

Where you are

Lesson 4 Building the Window

Create a new empty window

Add a PictureButton control

Display the attribute values

Add a script for the PictureButton control
= Save the window

Add an application script

Run the application

1  Select File>Save from the menu bar.

The Save Window dialog box displays so you can name and save your
window.

Save versus Save As
You could also select Save As. For a new window, Save and Save
As are equivalent.

2 Type w_employees for the window name.

3  Enter comments in the Comments box.

This documents your window.
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Save the window

4 Click OK.

PowerBuilder saves the new window in tutor_pb.pbl and returns you to
the Window painter.

Since you will be using the Window painter later, you will leave it
open.

About opening and closing painters

Up to this point in the tutorial you have closed each painter when you
finished using it. Typically you will want to leave several painters open
to keep them readily available as you work.
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Lesson 4  Building the Window

Add an application script

Where you are
Lesson 4 Building the Window
Create a new empty window
Add a PictureButton control
Display the attribute values
Add a script for the PictureButton control
Save the window
= Add an application script
Run the application

One of the most important functions of the PowerBuilder application object
is opening the initial window of the application. All application objects
have the appropriate instructions in the script for the Open event.

You will now build that script for your application.

1 Click the Application painter button on the PowerBar.
The Application painter displays.

Obiect name: tutor_pb Last modified: 11/3/94 12:55:24
Library name: c:\pb4\tutor_pb.pbl Size in bytes: 1503

Comments: This is the PowerBuilder tutorial application  Checked out by:
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Add an application script

Click the Script button in the PainterBar.

The PowerScript painter displays. This is the same PowerScript
painter you were in before, except this time you reached it from the
Application painter instead of the Window painter.

Type the following one-line script:

open(w_employees)

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

-PawerBuiIder - tutor_pb
Declare Compile Window Hel

elect Event g Paste Object . Paste Global

open{v_employees)

The Return button
on the PainterBar
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Lesson 4  Building the Window

PowerBuilder compiles your script and returns you to the Application

painter.

Obiject name:
Library name:

Cormments:

Tree Window Help

Application - tutor_pb

tutor_pb
c:\pbd'tutor_pb.pbl

This is the PowerBuilder tutorial application

Last modified:
Size in bytes:
Checked out by:

11/3/94 1255:24
1503
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Run the application

Run the application

Where you are
Lesson 4 Building the Window
Create a new empty window
Add a PictureButton control
Display the attribute vaiues
Add a script for the PictureButton conirol
Save the window
Add an application script
= Run the application

You can now run your application to see how it works.

Click the Run button on the PowerBar.
or
Select File>Run from the menu bar.

PowerBuilder prompts you to save the script you just wrote before
running the application.

= Application

Save changes to
c:\pbtutor_pb.pbiftutor_pb}?
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Lesson 4  Building the Window

2 Click Yes.

Your application runs. The script for the application Open event opens
your window.

Your window may not fully display. In the next lesson you will set its
opening position on the display screen.

Click the Exit PictureButton.
If necessary, drag the window so that you can access the button.

The script for the button's Clicked event executes. The window closes
and you return to the Application painter.

4  Select File>Close from the menu bar.

The Application painter closes and you return to the Window painter,
which you left open.

Now that the basic window is working, you can add a title and other
enhancements.
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LESSON 5
Enhancing the Window

In this lesson you will:

¢ Define the window's style, which includes adding a title and changing
some of the window's attributes

¢ Define the window's opening position on the screen

When you finish this lesson, your application window will look like this
during execution.

Maintain Employees

How long will this lesson take?
About 10 minutes.
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Define the window's style

Define the window's style

Where you are

Lesson 5 Enhancing the Window
®» Define the window's style

Define the window's opening position

Run the application

In the Window Style dialog box, you can set the window's title, its menu,
and attributes such as whether it is resizable.

1 Make sure your screen looks like this.
If not, open the Window painter and select the w_employees window.
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Lesson 5 Enhancing the Window

Select Design>Window Style from the menu bar.

The Window Style dialog box displays. The title bar text is
highlighted.

Type Maintain Employees
This replaces Untitled in the Title Bar box.

Deselect the Maximize Box checkbox.

Everything in the window will be visible at once so there will be no
need to maximize the window.

Deselect the Resizable checkbox.

This will prevent users from resizing the window during execution.

;i AppWorkSpace .

Click OK.

This closes the Window Style dialog box and returns you to the
Window painter workspace.
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Define the window's opening position

Define the window's opening position

Where you are
Lesson 5 Enhancing the Window
Define the window's style

= Define the window's opening position
Run the application

In the Window Position dialog box, you will set the opening position of the
window. You can access the Window Position dialog box from Design on
the main menu or from the popup menu for the window.

1 Move the pointer to an unused spot in the window and right-click.

The popup menu for the window displays.

in'::rul':"uilder—tuluripb ]
Design Declare Options Window Help

%

Color »
Icon... .
Pointer...
Paosition...
Style
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Lesson 5 Enhancing the Window

The screen

The window

Click Position.

The Window Position dialog box displays. The large rectangle
represents the entire screen. The small rectangle represents the relative
size and position of the window you are working on.

Click inside the small rectangle and drag it closer to the top of the
workspace.

This is where the window will display when it first opens during
execution.
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Define the window's opening position

4  Select the Center Horizontally checkbox.

This centers your window horizontally on the screen during execution.

Window Position

5 Click OK.
The Window painter displays.
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Lesson 5 Enhancing the Window

Run the application

® Run the application

Where you are

Lesson 5 Enhancing the Window
Define the window's style

Define the window's opening position

1

Click the Run button in the PowerBar.
or
Select File>Run from the menu bar.

PowerBuilder prompts you to save your changes.

Click Yes.

Your window displays. It is centered near the top of the screen, has a
title, and cannot be maximized or resized.

Maintain Employees

3 Click the Exit PictureButton.

The Window painter displays. Again, you will leave the Window
painter open.

Now you are ready to make this application work with the database.
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LESSON 6

Building the First DataWindow Object

DataWindow objects are one of the most powerful and useful features of
PowerBuilder. They can connect to a database, retrieve rows, display the
rows in various styles, and update the database.

In this lesson you will create a DataWindow object that retrieves and
displays the employees in the emp_tutorial table.

When you finish this lesson and preview the DataWindow object you
create, it will look like this. Note that the DataWindow object is not yet a
part of your application window.

DataWindow - d_emplist

How long will this lesson take?
About 20 minutes.
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Create the new DataWindow object

Create the new DataWindow object

Where you are

Lesson 6 Building the First DataWindow Object
» Create the new DataWindow object

Preview the DataWindow object

Save the DataWindow object

Create a group

Make cosmetic changes

1 Click the DataWindow painter button in the PowerBar (not in the Window
painter PainterBar).

The DataWindow painter opens and the Select DataWindow dialog
box displays.

 Application Libraries:
# :m: c:\pb4\tutor_pb.pbl

In the Select DataWindow dialog box, you can select an existing
DataWindow object and modify it, or you can create a new one. You
want to create a new DataWindow object.

104



Lesson 6 Building the First DataWindow Object

Click New.
The New DataWindow dialog box displays.

Select Quick Select as the data source.
Select Tabular as the presentation style.
Make sure that the Preview when built checkbox is deselected.

Click OK.

The Quick Select dialog box displays because you specified Quick
Select as the data source. The Tables box automatically lists all tables
in the current database. The current database is the Tutor_pb database,
which you created earlier.
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Create the new DataWindow object

5  Click emp_tutorial.

This opens the table and lists its columns.

ick Select

emp_salary

For this DataWindow, you select three columns.

6  Click emp_dept_idfirst.
Then click emp_id.
Then click emp_name.

PowerBuilder displays the selected columns in a grid at the bottom of
the Quick Select dialog box.

Tip
The column selection order determines the left to right display
order in the DataWindow.
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Lesson 6 Building the First DataWindow Object

'mp_status
mp_salary

You can use this area to specify sort criteria (SQL ORDER BY clause)
and selection criteria (SQL WHERE clause). In this case, you will only
specify sort criteria.

You will sort on emp_dept_id and within emp_dept_id on emp_id.

7 Inthe grid, click in the cell beside Sortand below Emp Dept ID.
A dropdown listbox displays.

Emp Dept Id Emp Id | Emp Name

Click in this cell

8 Select Ascending from the dropdown listbox.

Emp Deptld | Emp 1d Emp Name

This specifies sorting on the emp_dept_id column. Because this
column is first, it is the highest level of sorting.
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Create the new DataWindow object

Column headers
from the repository

The three columns
you selected

108

9 Click in the cell below the Emp Id heading.
Select Ascending from the dropdown listbox.

, N
Emp Dept}d, Emp Id \ Emp Name
Ascending Ascending &

iDescending
[not sorted) /

This specifies the next level of sorting.

10 Click OK.

PowerBuilder creates the new DataWindow object and displays it in
the DataWindow painter workspace.

In the header band, PowerBuilder displays the headings you specified in
the extended attributes information when you created the table in the
Database painter. They are just starting points; you can override them if
you want.



Lesson 6 Building the First DataWindow Object

Header band

Detail band

Summary band

(empty)

Footer band
(empty)

The DataWindow painter workspace is divided into four areas called
bands: header, detail, summary, and footer. You can modify these bands.
For example, you can change their sizes; add text, lines, boxes, or ovals;
and change colors and fonts. If a band is not open you can create as much
space as needed by pointing at the bar (the gray area with an up arrow),
pressing and holding the left mouse button, and dragging down until you
see the desired amount of space.
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Preview the DataWindow object

Preview the DataWindow object

Where you are
Lesson 6 Building the First DataWindow Object
Create the new DataWindow object
= Preview the DataWindow object
Save the DataWindow object
Create a group
Make cosmetic changes

You can preview your new DataWindow object immediately.

1  Click the Preview button in the PainterBar.

PowerBuilder displays the DataWindow as it will display during
execution. To make it realistic, PowerBuilder retrieves and displays
data in the DataWindow. Header information and the detail lines
display. If you had specified footer information, it would also display.

Header
Whitney, Fran

Cobb, Matthew
Breault, Robert
Shishoy, Natasha
Driscoll, Kurt
Guevara, Rodrigo
Gowda, Ram
Melkisetian, Terry

Detail

Pastor, Lynn
Lull, Kim
Rabkin, Andrew
Siperstein, Linda
Scott, David

Sullivan, Dorothy

All employees in the table display. Employees are sorted by
department ID then employee ID number, as you specified.

Click the Design button in the PainterBar.

You return to the DataWindow painter workspace.
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Lesson 6 Building the First DataWindow Object

DataWindow buffers previewed rows

The DataWindow preview function keeps previewed rows in
memory to speed up later previews. However, this may cause a
problem if you change the DataWindow's format. In this case, click
the Retrieve button on the PainterBar to refresh the display.
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Save the DataWindow object

Save the DataWindow object

112

Where you are
Lesson 6 Building the First DataWindow Object
Create the new DataWindow object
Preview the DataWindow object
= Save the DataWindow object
Create a group
Make cosmetic changes

Now you will name the DataWindow object and save it. As you refine and
improve the DataWindow object, you should save it periodically to keep
from losing work. Whenever you leave the DataWindow painter, you are
prompted to save your changes if you've made any.

1  Select File>Save from the menu bar.

The Save DataWindow dialog box displays. The insertion point is in
the DataWindows box.

2 Type d_emplist

This names the DataWindow object. The prefix d is standard for
DataWindow objects.

3  Enter comments in the Comments box.

Comments identify the DataWindow object and display in the Library
painter. Comments are optional.



Lesson 6 Building the First DataWindow Object

4  Click OK.

PowerBuilder saves the DataWindow object and closes the Save
DataWindow dialog box.

113



Create a group

Create a group

114

Where you are
Lesson 6 Building the First DataWindow Object
Create the new DataWindow object
Preview the DataWindow object
Save the DataWindow object
® Create a group
Make cosmetic changes

In preview, the DataWindow displays employee data sorted by department
ID, and within department ID by employee ID. However, it is not easy to
see where one department ends and another begins.

In this section, you will make the data easier to read. You will group the
data by department ID, display the department ID at the top of each page of
the DataWindow, and start each department on a new page.

To do this you will create a group and move the Department ID header and
the emp_dept_id column to a new area in the DataWindow.



Lesson 6 Building the First DataWindow Object

Create new group

1 Select Rows>Create Group from the menu bar.

The Specify Group Columns dialog box displays. You are going to
group on the emp_dept_id column.

2 Press and drag emp_dept_id from the Source Data box to the Columns
box.

To here

Drag from here

This groups information in the window by department ID.
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Create a group

3 Select the New Page on Group Break checkbox.

Specify Group Columns

This generates a new page in the DataWindow each time the
department ID changes.

4 Click OK.

PowerBuilder saves the grouping and returns to the DataWindow
workspace.
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Lesson 6 Building the First DataWindow Object

Band

Bar that identifies
a band

5

Notice that the DataWindow has new bands: a header and a trailer for
the group. The bars representing the header and trailer contain the
group number, the name of the column in the group, and an up arrow
pointing to the area. At this point, the bands for the group header and
trailer are narrow because they are empty.

indow - d_cmpli

Group bars

Click the Preview button.

Click the Next button in the PainterBar to see the page break between
Department 100 and Department 200.

The DataWindow now starts a new page for each department. Since
each page shows one department, it is unnecessary to repeat
emp_dept_id on each line. Let's make the department ID display in the
group header instead.

épanmentEmployee ID
1 100 562 Samuels, Peter
100 604 Wang, Albert
100 839 Marshall, Dean
100 862 Sheffield, John
100 958 Sisson, Thomas
100 Smith, Susan

100 Soo, Hing
100 Diaz, Emilio

Click the Design button in the PainterBar.

You return to the DataWindow painter workspace.
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Create a group

Move department ID to the group header

1 Move the pointer to the bar titled 1:Header group emp_dept_id until you
see a double-pointed arrow.
Drag the bar down to leave enough space for one line of information (see
the second picture below).

DataWindow —{united)

T — | I R

Move the pointer to
the group header bar
and drag it down

DataWindow - [untitled)

(s [0 J[s] [

New space

2 Move the pointer to the text for the Department ID heading, press the left
mouse button, and drag the text into the group header band.

DataWindow - d_emplist _

_D: Aim

T Avial

Drag from here
To here
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Lesson 6 Building the First DataWindow Object

3 Move the pointer to the emp_dept_id column in the detail area and drag it
to the right of the Department heading in the group header band.

Datanduw - d empllst

nﬁgﬁﬁﬁﬁ%ﬁ =]

Drag up to the
group header
band

The workspace looks like this after you put the Department heading
and the emp_dept_id column in the group header.

Dalannduw d emphsl

4  Click on the Employee ID heading.
Hold down the CTRL key and click on the Name heading.

The two items are selected. This is one method of selecting multiple
items.

You can also use lasso select to select multiple items

Another way to select multiple items is to press and drag across the
items to be selected. This is called lasso select; for a more detailed
explanation, see "Enhance the DataWindow Object" in Lesson 8,
"Building the Second DataWindow Object."
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Create a group

120

Press the left mouse button over either selected object and drag to the
right about one-half inch.
Release the left mouse button.

Use the cTRL+click technique to select the emp_id and emp_name
columns and drag them to the right about one-half inch.

When you are finished, your workspace should look something like
this.

‘DataWindow - d_emplist

ail1o | [=] [s[7{u] [=[=Ts] |




Lesson 6 Building the First DataWindow Object

Preview again

Click the Preview button.

PowerBuilder displays the DataWindow as it will display during
execution, and retrieves and displays data in it.

Again the employee data is sorted by department ID and then by
employee ID. However, the department ID now displays at the top of
the page.

i -
' DataWindow - d_emplist

Employee ID Name
Department 100

Whitney, Fran
105 Cobb, Matthew
160 Breault, Rohert
243 Shishov, Natasha
247 Driscoll, Kurt
243 Guevara, Rodrign
266 Gowda, Ram
278 Melkisetian, Terry
316 Pastor, Lynn
445 Lull, Kim
453 Rabkin, Andrew
479 Siperstein, Linda

Scott, David

Click the Next and Prior buttons to scroll through the data.

Notice the group breaks.

Click the Design button.

You return to the DataWindow painter workspace.
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Make cosmetic changes

Make cosmetic changes

Where you are
Lesson 6 Building the First DataWindow Object
Create the new DataWindow object
Preview the DataWindow object
Save the DataWindow object
Create a group
= Make cosmetic changes

You can now make cosmetic changes to the DataWindow.

This example changes the background color and the colors used to display
the department ID.

1 Move the pointer to the emp_dept _id column in the group header band
and right-click.
Select Color from the popup menu.
Select Background.

The color menu displays.

_DataWindow - d_emplist

LY N R

Edit Styles
Font...
Format...
Name...
Pointer...
Query Criteria  »
Validation...

Bring to Front
Send to Back
Layer »
Slide

Clear

2 Select the yellow box in the color menu.

The background of the column immediately turns yellow.
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Lesson 6 Building the First DataWindow Object

3 Move the pointer back to the emp_dept _id column in the group header
band and right-click.
Select Color from the popup menu.
Select Text.

4  Select the dark blue box in the color menu.

The text of the column immediately turns dark blue.

5 Move the pointer anywhere in the Header band, Group Header band, or
Detail band, being careful not to point at any items or click in the bars.

You might click in this area.

Don't click in the
bars

6 Right-click.
Select Color from the popup menu.

7  Select the light gray box in the color menu.

The DataWindow background immediately turns light gray.
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Make cosmetic changes

8 Click the Preview button to see how it looks.

DataWind

9  Click the Design button.

You return to the DataWindow painter workspace.

10 Select File>Close from the menu bar.

PowerBuilder prompts you to save your changes.

Save changes to
c:\pb4itutor_pb.pbl(d_emplist}?

11 Click Yes.

PowerBuilder closes the DataWindow painter and returns to the
Window painter.

At this point, you have a DataWindow object named d_emplist stored in
the tutor_pb.pbl library. Next you will use this new object in your window.
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LESSON 7

Adding the First DataWindow

After you create and save a DataWindow object, you can use it in a
window. To do this, you place a DataWindow control in the window,
associate the DataWindow object with it, and then write scripts for it.

In this lesson you will:
¢ Place a DataWindow control in the window you have built
¢ Associate the DataWindow object you built with the control

¢ Write a script for the window Open event to make the new
DataWindow retrieve and display all the employees

¢ Update the script for the application Open event

¢ Add a script for the application Close event

When you finish this lesson, your application window will look like this
during execution.

How long will this lesson take?
About 30 minutes.
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Place the DataWindow control in the window

Place the DataWindow control in the window
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Where you are
Lesson 7 Adding the First DataWindow

= Place the DataWindow control in the window

Select the DataWindow object to display in the control
Specify attributes of the DataWindow control

Add a script for the Open event for the window

Assign values to SQLCA

Add a script for the Close event for the application
Run the application

Using script comments

Make sure you are in the Window painter with the w_employees window
displayed.

If you are not, open the Window painter and select the w_employees
window.

Click the DataWindow button in the PainterBar (not in the PowerBar).

PowerBuilder will place a DataWindow control at the next point you
click in the workspace. A DataWindow control displays a
DataWindow object in the window.




Lesson 7 Adding the First DataWindow

3 Click near the upper-left corner of your window.

A small rectangle displays. This is the DataWindow control.

DataWindow
control

You can change the size and shape of the DataWindow control.
4  Make sure the control is selected (has black boxes in each corner).

If it is not selected, click anywhere inside the DataWindow control to
select it.

5  Move the pointer to the lower-right corner of the DataWindow control.

The pointer turns into a slanting, double-headed arrow.
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Place the DataWindow control in the window

6 Hold down the mouse button and drag the control until it fills about half
of your window's height and most of your window's width.

Your screen should look like this now.
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Lesson 7 Adding the First DataWindow

Select the DataWindow object to display in the
control

Where you are
Lesson 7 Adding the First DataWindow
Place the DataWindow control in the window
= Select the DataWindow object to display in the control
Specify attributes of the DataWindow control
Add a script for the Open event for the window
Assign values to SQLCA
Add a script for the Close event for the application
Run the application
Using script comments

1 Double-click inside the DataWindow control.

The Select DataWindow dialog box displays.

Select DataWindow

ts:

Employee List DataWindow obiject for tutor_pb application

¢ c:\pb4\tutor_pb.pbl

The listbox at the top lists the DataWindow objects in the current
library. At this point, there is only the DataWindow object you just
built, d_emplist.
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Select the DataWindow object to display in the control

2 Click OK.

The DataWindow dialog box displays some of the attributes of the
DataWindow control.

DataWindow - d_emplist
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Lesson 7 Adding the First DataWindow

Specify attributes of the DataWindow control

Where you are

Lesson 7 Adding the First DataWindow

Place the DataWindow control in the window

Select the DataWindow object to display in the control
= Specify attributes of the DataWindow control

Add a script for the Open event for the window

Assign values to SQLCA

Add a script for the Close event for the application

Run the application

Using script comments

As with most PowerBuilder objects and controls, you can change the visual
and functional attributes of the DataWindow control. In this case, you just
want to add a vertical scroll bar to make it easy to scroll up and down to

see all the employees. Additionally, you will specify a meaningful name for
the DataWindow control.

1 Use the cursor to highlight the 1 of dw_1 in the Name box.
Type master.

2  Select the VScroll Bar checkbox.

Do not change the default values of the other attributes.
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Specify attributes of the DataWindow control

3 Click OK.

The Window painter displays with the DataWindow object named
d_emplist in the dw_master DataWindow control.

You see the headings. However, you do not see any group headings or data.
The DataWindow will not execute its SELECT statement until you add
some scripts and run the application. Also, you do not see the vertical
scroll bar you requested; it displays only when you run the application.
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Lesson 7 Adding the First DataWindow

About making the DataWindow object work
To make the DataWindow object work, you need to tell it at least two
things:

¢ Where to obtain its data during execution
¢ What to do (for example, retrieve, or update)

Earlier, when you previewed the DataWindow object, you were in the
PowerBuilder development environment. PowerBuilder obtained the
information about database name, password, and other database
variables from your PowerBuilder Preferences file (the PB.INI file).

But a user will not have the development environment and therefore will
not have a PB.INI file. So you must provide the DataWindow object all
the information it needs to access the database.

You can code all this information into your application. But that is often
too inflexible. In practice, you will probably read the necessary
information from a file or display a window for the user to enter the
required information.

Or you can use a combination of both methods. For example, you can
get the database name from a file and request the password in a window.

Passing database information to the DataWindow control

To pass required database information to a DataWindow control, you
use a PowerBuilder transaction object. PowerBuilder provides a default
transaction object. You can easily create more if you need them.

The default transaction object is named SQLCA, which stands for SQL
Communications Area. SQLCA is global (that is, it is available in any
script) and it has several attributes (including database name and
password).

A transaction object has attributes for sending information fo the
database and attributes for obtaining information (success or failure
information for each database activity) from the database.

&> For more information about transaction objects, see Building
Applications.
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Add a script for the Open event for the window

Add a script for the Open event for the window
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Where you are
Lesson 7 Adding the First DataWindow
Place the DataWindow control in the window
Select the DataWindow object to display in the control
Specify attributes of the DataWindow control
= Add a script for the Open event for the window
Assign values to SQLCA
Add a script for the Close event for the application
Run the application
Using script comments

In this section you will write a script that tells the DataWindow object
where to obtain its data and what database activities to perform. You will
type some commands and use the Object browser to paste in other
commands. Using the Object browser helps you to select the appropriate
function and identify the necessary arguments.

&~ For more information on the Object browser, see the User's Guide.

The location for this script is in the Open event for the window (nof the
DataWindow control). That is because you want the DataWindow to
retrieve all its data when the window opens.

By the time the window actually displays on the screen, all the employee
names will be ready for display.



Lesson 7 Adding the First DataWindow

Move the pointer to an unused space in your window and right-click.

The popup menu for the window displays.

~ Window - w_employees

#[10][¢]

Color
lcon...
Pointer...
Pasition...
Style
Title...
Type

Click Script.

The PowerScript painter opens for the window.

Make sure you are writing a script for the Open event for the window.
The title bar of the PowerScript painter should read:

Script - open for w_employees

If the title is incorrect
If the object is not w_employees, select Edit> Select Object from
the menu bar and select w_employees.

If the event is not the Open event, click the Select Event listbox and
select Open.
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Add a script for the Open event for the window

4  Type the first line of the script to connect to the database.

Press ENTER to position the insertion point at the beginning of a new line.
Add an IF statement to check SQLCA.SQLCODE (an attribute of the
transaction object) for successful completion (press ENTER at the end of
each line).

CONNECT using SQLCA;

IF SQLCA.SQLCODE <> 0 THEN

MessageBox("Connect Error",SQLCA.SQLERRTEXT)

HALT
END IF

PowerBuilder is not case sensitive, so use the case you prefer.

5 Paste the next line of the script.

To paste, follow these directions:

1 Press ENTER to position the insertion point at the beginning of the
next line.
Click the down arrow to the right of the Paste Object box.

Script - ope~ ror w_employees

Messageﬂux( 'C
HALT
END IF

2  Click dw_master.
Type a period.

r Script - open for w_employees

Select Event :Z Paste Object :i Paste Global E Paste Instance 3

CONNECT using SQLCA;

IF SQLCA.SQLCODE <> @ THEN
MessageBox{(“Connect Error",SOLCA.SQLCA.SQLERRTEXT)
HALT

END IF

dw_master.
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Lesson 7 Adding the First DataWindow

3 Click the Browse button.
or
Select Edit>Browse Objects from the menu bar.

The Browse Objects dialog box opens and displays the windows in
the current application.

Make sure you are in Browse Objects

Make sure that you are in the Browse Objects (plural) dialog box
and not the Browse Object (singular) dialog box, which displays
attributes and functions for the current object only (in this case
the w_employees window).

4  Click the window name (w_employees) if it is not selected.
5  Click DataWindow in the Object Types box.

Click Functions in the Paste Category box.

DataWindow functions display in the Paste Values box.
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Add a script for the Open event for the window

6 Scroll to the SetTransObject function and double-click it.

I Browse Objects

| |setsqlselect [ string s ) returns int
settaborder (int c. int n ) returns int
_{settaborder ( stiing c. int n ) returns int
isettext ( string t) returns int
isettrans [ transaction t ] returns int
| settransobiect [ transaction t | returns int
setvalidate [ int c, string m ) returns int
| |setvalidate [ string c. ing m ) returns int
setvalue [ int c. i ing v ) returns int
~ {setvalue [ stiing c, i, string v ] returns int
 |sharedata ( datawindow d ) returns int

The SetTransObject function and its prototype parameter display
in your script.

Scnpl open forw employees

Select Event :j Paste Object :2 Paste Global :] Paste Instance ;i

CONNECT using SQLCA;

IF SQLCA.SQLCODE <> 8 THEN
MessageBox("'Connect Error",SQLCA.SQLCA.SQLERRTEXT)
HALT

END IF

du_master.settransobject ( )

Prototype parameter

7  Click the down arrow to the right of Paste Global.
The list of global variables displays.

Script - open for w_employees

Select Event %1 Paste Object :] 41 Paste Instance g

dynamicdescriptional #

CONNECT using SQLCA; dynamicstagingarea

IF SQLCA.SQLCODE <> @ THEN error ernor
HessageBox("Connect Error',SQL{message message T)
HALT transaction sqlca

END IF

dw_master.settransobject ( m

138



Lesson 7 Adding the First DataWindow

8 Click transaction sqlca.

The variable sqlca displays as the argument in the SetTransObject
function.

Select Event - Paste Object ;3 Paxle Global E Paste Instance .

CONNECT using SQLCA; t
IF SQLCA.SQLCODE <> @ THEN
HessageBox{"Connect Error",SQLCA.SQLCA.SQLERRTEXT)
HALT
END IF
duw_master.settransobject ( sqlca )

Type the next lines of the script:

IF dw_master.Retrieve () = -1 THEN
ROLLBACK using SQLCA;
MessageBox("Retrieve", "Retrieve failed")
ELSE
COMMIT using SQLCA;
dw_master.SetFocus()
dw_master.SetRowFocusIndicator(Hand!)
END IF

Your completed script should read like this:

Select Event 3 | Paste Dbject . Paste Global :3 Paste Instance 1

CONNECT using SQLCA;

IF SQLCA.SQLCODE <> 8 THEN
HessageBox('Connect Error' ,SQLCA.SQLERRTEXT)
HALT

END IF

dw_master.settransobject { sqlca )

IF duw_master.Retrieve() = -1 THEN
ROLLBACK using SQLCA;
MessageBox{"'Retrieve”,"Retrieve failed")

ELSE
COMMIT using SQLCA;
du_master.SetFocus()
du_master.SetRowFocusIndicator(Hand?)

END IF

| * 0003:0035
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Add a script for the Open event for the window

PowerScript summary

140

CONNECT using SQLCA;

This line uses the SQLCA transaction object to connect to the database. In
just a few minutes you will write a script for the Open event for the
application that puts values into SQLCA.

IF SQOLCA.SQLCODE <> 0 THEN
MessageBox ("Connect Error",SQLCA.SQLERRTEXT)
HALT
END IF
These lines check whether the CONNECT statement was successful. If the
connect fails, it displays a message box and exits the application.

dw_master.settransobject ( sqlca )

This line tells the DataWindow object (in the control dw_master) to look in
the transaction object named SQLCA for the database information such as
database name and password.

IF dw_master.Retrieve () = -1 THEN
ROLLBACK using SQLCA;
MessageBox ("Retrieve"”, "Retrieve failed")
ELSE
COMMIT using SQLCA;
dw_master.SetFocus()
dw_master.SetRowFocusIndicator (Hand!)
END IF

These lines execute the DataWindow's Retrieve function, which performs
the SQL Select statement associated with the DataWindow object and
places the retrieved rows in the dw_master DataWindow control. If the
Retrieve succeeds, it performs a database commit, sets focus to the first row
in the DataWindow control, and uses the enumerated variable Hand! to
establish the hand pointer as the current row indicator. If the Retrieve fails,
it performs a database rollback and displays a message.

&~ For more information on enumerated data types, Commit, and
Rollback, see the PowerScript Language manual. For more information on
the MessageBox, SetFocus, and SetRowFocusIndicator functions, see the
Function Reference.

Since this script executes as the window opens, the employees will show in
the DataWindow control when the window first displays.



Lesson 7 Adding the First DataWindow

Click the Return button in the PainterBar.
or
Select File>Return from the menu bar.

PowerBuilder compiles the script. If there are errors, an error window
opens at the bottom of the screen. Correct your errors, then click the
Return button again. You return to the Window painter.

8 Select File>Close from the menu bar.

PowerBuilder displays the Save Changes message box.

9 Click Yes.

PowerBuilder closes the Window painter and returns you to the
PowerBar.

Now it is time to assign values to SQLCA.
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Assign values to SQLCA

Assign values to SQLCA
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Where you are
Lesson 7 Adding the First DataWindow
Place the DataWindow control in the window
Select the DataWindow object to display in the control
Specify attributes of the DataWindow control
Add a script for the Open event for the window
= Assign values to SQLCA
Add a script for the Close event for the application
Run the application
Using script comments

Since SQLCA is global, it may be used by many windows. So it is a good
idea to get its values filled in at the very beginning of your application (that
is, in the script for the application's Open event).

In this tutorial, the script will obtain the required information from the
PB.INI file by using the ProfileString function.

You can use an application-specific file instead of PB.INI

Even though the data is coming from PB.INI in this example, the
ProfileString technique is the same as if you read from an application-
specific file such as APPL.INI.

1 Click the Application painter button in the PowerBar.

The Application painter workspace displays. The tutor_pb application
is the current application.

Application - lu.tor_pb

Obiject name: tutor_pb modified: 11/3/9416:12.29
Library name: c:\pbdhtutor_pb.pbl Size in bytes: 1697

Comments: This is the PowerBuilder tutorial application  Checked out by.




Lesson 7 Adding the First DataWindow

Click the PowerScript button in the PainterBar.

The PowerScript painter displays the one-line script you entered
earlier.

Y Scnpt open fortulm ph

Se|ecl Event . Pasle Object . Pasle Global .‘

open{u_enployees)|

Since the script for the Open event for the window uses SQLCA, you
need to assign values to SQLCA before opening the window.

The two lines you will enter use the ProfileString function to pass
values for the DBMS and DbParm attributes of SQLCA. These are the
two values the Watcom SQL database needs at connect time.

Each database has specific requirements
The values needed at connect time depend on the database you are
connecting to.

& For more information, see Connecting to Your Database.

3 Position the insertion point (I-beam) before open(w_employees) in the
script.
Press ENTER twice to make some room.

This adds two empty lines before the open statement.
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Assign values to SQLCA

4 Type the new lines exactly as they appear below.

SQLCA.DBMS=ProfileString &
("PB.INI", "Database", "DBMS"," ")
SQLCA.DbParm=ProfileString &
("PB.INI", "Database", "DbParm"," ")

%E Scnpt open for tutor_pb

Ampersand is —————
the continuation (PB-INE","Database NBafis”, " )
CharaCter KQLCR.DbParm=ProflleStr1ng &

("'PB.INI","Database”,"DbParm™,"” ")

open({w_employees)

The ProfileString functions look in the [Database] section of the
PB.INI file to determine the DBMS and DbParm attributes.

PowerScript continuation character

Ampersand (&) is the PowerScript continuation character. If you
want to use more than one line for a statement, you must use the
continuation character.

5 Click the Return button.
or
Select File>Return from the menu bar.

PowerBuilder compiles the script. If there are errors, an error window
opens at the bottom of the screen. Correct your errors, then select
Return again. You return to the Application painter.

If you have trouble compiling
You can comment out the lines in your script that do not compile.

& See "Using script comments" on page 149.
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Lesson 7 Adding the First DataWindow

Add a script for the Close event for the
application

Where you are
Lesson 7 Adding the First DataWindow
Place the DataWindow control in the window
Select the DataWindow object to display in the control
Specify attributes of the DataWindow control
Add a script for the Open event for the window
Assign values to SQLCA
= Add a script for the Close event for the application
Run the application
Using script comments

In this section you will write a script that tells the application to disconnect
from the Database.

Click the PowerScript button in the PainterBar.

The PowerScript painter displays the Open event script you entered
earlier.

2 Click the down arrow next to Select Event at the top of the PowerScript
painter and select Close.

The title bar of the PowerScript painter should read:

Script - close for tutor_pb

3 Type the following lines exactly as they appear here.

DISCONNECT using SQLCA;
IF SQLCA.SQLCODE <> 0 THEN

ROLLBACK using SQLCA;

MessageBox( "Disconnect"”,SQLCA.SQLERRTEXT)
END IF

Scnpt close for tutgr pb

Select Event . #/Paste Object . Paste Global ! Paste Instance :;

DISCONNECT using SQLCA;
IF SQLCA.SQLCODE <> 8@ THEN
ROLLBACK using SQLCA;
MessageBox("'Disconnect',SQLCA.SQLERRTEXT)
END IF
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Add a script for the Close event for the application

Click the Return button.
or
Select File>Return from the menu bar.

PowerBuilder compiles the script. If there are errors, an error window
opens at the bottom of the screen. Correct your errors, then select
Return again. You return to the Application painter.

If your script continues to have errors, you can turn it into comments
to leave the PowerScript painter. For how, see "Using script
comments" on page 149.

PowerScript summary

DISCONNECT using SQLCA;
This line uses the SQLCA transaction object to disconnect from the
database.

IF SQLCA.SQLCODE <> 0 THEN

ROLLBACK using SQLCA;

MessageBox ( "Disconnect" , SQLCA.SQLERRTEXT)
END IF
These lines check whether the DISCONNECT statement was successful. If
the disconnect fails, it performs a database rollback and displays a message
box.

DISCONNECT includes COMMIT functionality

The Disconnect statement performs an implicit Commit for the specified
transaction object, there is no need to code a Commit statement in this
script.
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Lesson 7 Adding the First DataWindow

Run the application

Where you are
Lesson 7 Adding the First DataWindow
Place the DataWindow control in the window
Select the DataWindow object to display in the control
Specify attributes of the DataWindow control
Add a script for the Open event for the window
Assign values to SQLCA
Add a script for the Close event for the application
= Run the application
Using script comments

Click the Run button in the PowerBar.
or
Select File> Run from the menu bar.

PowerBuilder prompts you to save your changes.

2 Click Yes.

Your window opens and displays a list of employees. You can scroll
up and down to see them all. Your application has just connected to
the database and retrieved information.

Maintain Employees

3 Click the Exit PictureButton.

You return to the Application painter.
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Run the application

4 Select File>Close from the menu bar.

PowerBuilder closes the Application painter.
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Using script comments

Where you are
Lesson 7 Adding the First DataWindow
Place the DataWindow control in the window
Select the DataWindow object to display in the control
Specify attributes of the DataWindow control
Add a script for the Open event for the window
Assign values to SQLCA
Add a script for the Close event for the application
Run the application
= Using script comments

PowerBuilder does not save a script until the script compiles successfully.
So to save a script that does not yet compile, you can turn the script into
comments. The compiler ignores the comments and saves the script. You
can come back later, uncomment the code, and fix the problem.

A comment in PowerBuilder is indicated by either:
¢ Two forward slashes (//) at the start of a single-line comment.

¢  Aslash and an asterisk (/*) at the start and an asterisk and a slash (*/)
at the end of a single-line or multiline comment.

| To convert a line to a comment
Position the insertion point (I-beam) anywhere in the line and click the
Comment button.

To convert a group of lines to comments
Drag through the lines selecting all or any part of them. Then click the
Comment button.

To "uncomment" a line
Position the insertion point anywhere in the line and click the Uncomment
button.

To uncomment a group of lines
Drag through the commented lines selecting all or any part of them. Click
the Uncomment button.
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Using script comments

To select all lines for commenting or uncommenting
Click the Select All button or press CTRL+A.
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LESSON 8

Building the Second DataWindow Object

In this lesson you will create a second DataWindow object to show the
details for a selected employee.

When you finish this lesson and preview the DataWindow object, it will
look like this.

How long will this lesson take?
About 20 minutes.
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Create the new DataWindow object

Create the new DataWindow object
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Where you are

Lesson 8 Building the Second DataWindow Object
®» Create the new DataWindow object

Preview the DataWindow object

Save the DataWindow object

Enhance the DataWindow object

To create this DataWindow object, you will:

¢

*
14
.

Select the data source and style
Select the table and columns
Define a retrieval argument

Specify a WHERE clause




Lesson 8 Building the Second DataWindow Object

Select the data source and style

Click the DataWindow painter button in the PowerBar.

The DataWindow painter opens and the Select DataWindow dialog
box displays. It lists the d_emplist DataWindow, which is the one you
created.

Select DataWindow

| Employee List DataWindow
_ | application

2 Click New.
The New DataWindow dialog box displays.

3 Click SQL Select in the Data Source box.

Choosing SQL Select will take you to the Select painter, where you
can access SQL options.

In the first DataWindow, you chose Quick Select. This let you retrieve
all the employees without actually going to the Select painter.

In this DataWindow, you want to retrieve data about the employee
highlighted in the dw_master DataWindow control. You need to
define a retrieval argument and WHERE criteria so you can pass an
argument to the DataWindow during execution. In this case you will
be passing the employee number. Retrieval arguments and WHERE
criteria are defined in the Select painter.
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Create the new DataWindow object

4  Click FreeFormin the Presentation Style box.

5 Click OK.

Since the data source is SQL Select, you go to the Select painter and
the Select Tables dialog box displays.

Select Tables

emp_tutorial
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Select the table and columns

1 Click emp_tutorialin the list of tables.

2 Click the Open button.

The Select painter displays the table and its five columns.

DataWindow - (untitied)

3 Click each column name starting at the top with emp_id down to
emp_salary.

After you click a column name, the name is highlighted and displays
in the Selection List area along the top of the workspace.

DataWindow - (untitled)
Selection list ————————

area
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Create the new DataWindow object

To quickly select all the columns

Point to the emp_tutorial heading area, click the right mouse
button, and then click Select All. PowerBuilder highlights the
columns in the table and displays them in the selection list.

Click the Syntax tab if it's not already on top.

The generated SELECT statement displays in the tab area.

E in::.r—E;l‘jilder - tutor_pb T~
i Fi Objects Options Window Help
] % ) m 3

DataWindow - [untitled)

Tab area
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Define a retrieval argument

1 Select Objects>Retrieval Arguments from the menu bar.

The Specify Retrieval Arguments dialog box displays.

2 In the Name box, type employee_number

The default data type is Number, which is what you want.

About retrieval argument names

You can choose any name you want for the retrieval argument; it is
just a placeholder for the value you will pass during execution.
Nonetheless, it is a good idea to make the name meaningful.

3 Click OK.

The retrieval argument is defined. Next you need to specify the
WHERE clause that uses the retrieval argument employee_number.
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Create the new DataWindow object

Specify a WHERE clause

The WHERE clause uses the retrieval argument to retrieve a specific
employee.

Click the Where tab.
The Where tab displays.

2  Click in the box below Column.

3  Click the down arrow.

4  Click "emp_tutorial"."emp_id".

It displays immediately and places an equal sign (=) in the Operator
box. This is what you want, so do not change it.

5 Point in the box below Value and click the right mouse button.
The popup menu displays.

Columns...
Functions...
Arguments.

Value...
Select...
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Click on Arguments.
The Arguments dialog box displays.

It contains the retrieval argument you specified earlier
(employee_number) . The colon before employee_number indicates it
is a PowerBuilder variable that can be used as an argument in a SQL
statement.

Click :employee_number.

Click Paste.
The Where tab displays with the retrieval argument.

Click the Syntax tab.
The SELECT statement displays in the tab area.
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Create the new DataWindow object

10 Scroll down through the tab until you see the generated WHERE clause.

You have now created a complete SQL SELECT statement that says
select all five columns from the emp_tutorial table where the emp_id
column is equal to an argument that will be supplied during execution.

Click the Design button in the PainterBar.

PowerBuilder creates the new DataWindow object and displays it in
the DataWindow painter workspace.

PowerBuilder uses the labels you specified in the extended attribute
information in the Database painter. The labels are just the starting
values; you can change them if you want.
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Preview the DataWindow object

Where you are
Lesson 8 Building the Second DataWindow Object
Create the new DataWindow object
= Preview the DataWindow object
Save the DataWindow object
Enhance the DataWindow object

You can preview your new DataWindow object immediately.

1 Click the Preview button in the PainterBar.

Since this DataWindow object requires a retrieval argument, the
Specify Retrieval Arguments dialog box displays.

PowerBuilder prompts for the argument. When you put this
DataWindow into your application, you will write a script that will
pass the required argument to the DataWindow automatically.

Specify Retrieval Arguments

PowerBuilder remembers your retrieval argument

The next time you preview the DataWindow, PowerBuilder will go
directly to the DataWindow display, using the retrieval argument
you specified the first time. PowerBuilder stores the argument until
you leave the DataWindow painter. To access information for
another employee, click the Retrieve button, which redisplays the
Specify Retrieval Arguments dialog box.
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Preview the DataWindow object

2 Type an employee number (for example, 102, 105, or 243) and press
ENTER.

The DataWindow object connects to the database and retrieves the
requested employee.

3 Click the Design button.

You return to the DataWindow painter workspace.
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Save the DataWindow object

Where you are
Lesson 8 Building the Second DataWindow Object
Create the new DataWindow object
Preview the DataWindow object
® Save the DataWindow object
Enhance the DataWindow object

Now you will name the DataWindow object and save it. You could wait to
save it until you are leaving the painter, but it's good practice to save your
work frequently.

1  Select File>Save from the menu bar.

The Save DataWindow dialog box displays.

Save DataWindow

d_emplist

\pb4\tutor_pb.pbl

2 Inthe DataWindows box, type d_employee
In the Comments box, type a comment.

3 Click OK.

You return to the DataWindow painter.
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Enhance the DataWindow object

Enhance the DataWindow object

Where you are
Lesson 8 Building the Second DataWindow Object
Create the new DataWindow object
Preview the DataWindow object
Save the DataWindow object
®» Enhance the DataWindow object

In this section you will modify the DataWindow object. You will:
¢ Rearrange the columns and text
¢ Define a RadioButton edit style for the Status column

¢ Define a 3D Lowered border style for all columns

When you are done, your DataWindow will look like this.

Columns in FreeForm DataWindows
Data fields on FreeForm style DataWindows are still called columns,
even though they're shown in a nontabular display.
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Rearrange the columns

1 Click Status: and drag it to the top right of the DataWindow.

3 Make this box bigger.

Do this by moving the pointer over the lower-right corner until it turns
into a slanting, two-headed arrow. Drag the lower-right corner of the
box until it is about an inch and a half wide and an inch high. The
complete name, emp_status, now displays.

‘ _DataWindow - d_employee
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Enhance the DataWindow object

4  Move the pointer above and to the left of the label Salary:
Press and hold the left mouse button.
Drag until the shaded box surrounds both the Salary: label and the
emp_salary field.

5 Release the left mouse button.

The two items are selected. This is called lasso select. It's a handy
technique for selecting multiple items.

6 Click either selected object and drag both objects up about half an inch
so they are closer to the Name heading and emp_name column.

Mann ow-d employee

' _ﬁjiﬂﬂgﬁ )

Tip

You can also move selected items using the cursor keys.
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7 Drag the horizontal bar named Detail until it is just under Salary.
This makes the entire DataWindow a little shorter.

DataWindow - d_employee B
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Enhance the DataWindow object

Change the edit style

By default, DataWindow objects display the data they retrieve in edit
boxes. But by using edit styles, you can display the data as radio buttons,
checkboxes, dropdown listboxes, and dropdown DataWindows.

It's efficient to assign edit styles in the Database painter

In the Database painter, you can define and assign edit styles to
columns. Then the DataWindow painter will use the edit styles
automatically as the defaults whenever you generate a DataWindow that
uses the columns. You can always override the defaults in the
DataWindow painter.

In this DataWindow, you will change the edit style for emp_status from an
edit box to radio buttons.

1 Move the pointer to the emp_status box and right-click.

The popup menu displays.

2  Click Edit Styles.
Then click Radio Buttons.

Attributes...
Autosize Height

Check Box...
DropDownDataWindow... |

Format... DropDownListBox...
Name... v Edit...

Pointer...
Query Criteria <_Radio Buttons...

Validation...

Bring to Front
Send to Back
Layer
Slide

The RadioButton Style dialog box displays.
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Lesson 8 Building the Second DataWindow Object

3 Click in the box under Display Value.

In this area you will create a code table. After typing each display
value and data value press the DOWN ARROW key to display a line for
the next value.

4  Type the following display and data values:

Display value | Data value
Active A
On Leave L
Terminated T

The completed dialog box should match the following.

Press the bown
ARROW key
between rows
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Enhance the DataWindow object

170

Click OK.

The display returns to the DataWindow painter workspace. The three
display values you specified now display in the box under Status. You
may need to change the size of the box to accommodate the radio
buttons.

At this point, your DataWindow object should look approximately like
this.

B;'{a\viﬁdﬂw . dierﬁplmyée _

You just created a DataWindow object code table. Now, whenever the
DataWindow object reads A from the database, it will mark the Active
radio button as the current value.

The code table works in the other direction, too

For example, when a user selects the On Leave radio button, the
next time the DataWindow object processes an update request, it
will send L to the database.
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Change the border style

By default, the columns displayed in a DataWindow have no border. By
using border styles, you can enhance DataWindow display and emulate the
look of many current applications.

In this DataWindow, you will change the border style for all columns from
none to 3D Lowered.

1 Select Edit> Select> Select Columns from the menu bar.

This selects all columns (leaving labels unselected).

You can also use cTRL+click
You can also use the CTRL+click technique to select multiple
columns one by one.

2 Point to any of the selected columns and right-click.

3  Click Border.

Attributes
Autosize Height

Border

Underline
Edit Styles Box
Font... Resize
Format... Shadow box

Name... D Baiced
Bointer.. (73D Lowered |
Query Criteria

Validation...

Bring to Front

Send to Back

Layer

Slide
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Enhance the DataWindow object

4  Click 3D Lowered.
The DataWindow redisplays with the new border style.

DataWindow - d_employee

rAial__________|e]f10 ]

o
-

. [gﬁmﬂwwm

.
.
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Preview again

Click the Preview button in the PainterBar.

The DataWindow connects to the database, uses the argument you
specified the last time Preview was requested to execute the SELECT
statement, and retrieves the specified employee.

You may need to specify a retrieval argument

If you have closed the DataWindow painter since the last Preview
was requested, PowerBuilder will display the Specify Retrieval
Arguments dialog box. If so, type an employee number (for
example, 102, 105, or 243) and click OK.

To change an employee's status

Click one of the radio buttons. Then click the Updt DB button in
the PainterBar to update the database (if you're using PowerTips,
the button text is Save Changes).

Click the Design button.
You return to the DataWindow painter workspace.

At this point, you could make many other changes to the DataWindow
object. For example, you could change colors, add lines, remove
columns, and change labels and display formats.

For this tutorial, the DataWindow object is ready to be used in the
window you created earlier.
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Enhance the DataWindow object

3 Select File>Close from the menu bar.

PowerBuilder prompts you to save your changes.

4 Click Yes.

The DataWindow painter closes.
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LESSON 9

Adding the Second DataWindow

In this lesson you will add the second DataWindow (control and object) to
your window. When you finish this lesson, this is what your application
window will look like during execution.

Maintain Employees
7 e

How long will this lesson take?
About 15 minutes.
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Add the DataWindow control and object

Add the DataWindow control and object

Where you are
Lesson 9 Adding the Second DataWindow
®Add the DataWindow control and object
Preview the window
Build a DataWindow script
Extend the script for the Open event for the window
Run the application

1 Click the Window painter button in the PowerBar.
Open the w_employees window.

Your window displays with a DataWindow control and a
PictureButton.
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2 Click the DataWindow button in the PainterBar (not in the PowerBar).

3 Click below the first DataWindow near the left edge.

A rectangular DataWindow control displays.

4 Change the shape of the control so that it looks like this.
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Add the DataWindow control and object

5 Double-click inside the DataWindow control.

The Select DataWindow dialog box displays.

1 tutor_pb application

;. c:\pb4\tutor_pb.pbl

Notice that both your DataWindow objects (d_emplist and
d_employee) are stored in this library and listed.

6 Double-click d_employee to select it.

The DataWindow dialog box displays some of the attributes of the
DataWindow control.

Notice that since your window already has a DataWindow control,
PowerBuilder assigns this control the default name dw_1. You will
change the name to dw_detail.
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7 Use the cursor to highlight the 1 of dw_1 in the Name box.
Type detail.

8 Click OK.
The Window painter displays.

9  Adjust the size and shape of the DataWindow control if necessary.

If you do not see all the fields in the DataWindow control, make it
bigger.
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Preview the window

Preview the window

Where you are
Lesson 9 Adding the Second DataWindow
Add the DataWindow control and object
= Preview the window
Build a DataWindow script
Extend the script for the Open event for the window
Run the application

When you are in the Window painter workspace, you can preview your
window to see how it looks.

1 Select Design>Preview from the menu bar.

Your window displays and you can check its size, location, color,
object placement, and other style features. However, this is strictly a
visual preview; you cannot check how the scripts work.

2 Select Design>Preview from the menu bar again.

The preview window closes and you return to the Window painter
workspace.
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Build a DataWindow script

Where you are
Lesson 9 Adding the Second DataWindow
Add the DataWindow control and object
Preview the window
= Build a DataWindow script
Extend the script for the Open event for the window
Run the application

In this section you will build a script to create a Master/Detail application.
Here's how it will work when you are done:

¢ When the window initially opens, a list of all employees displays in
the top DataWindow control and detail information for the first
employee displays in the bottom DataWindow control.

¢ When a user moves through the list of employees using the UP ARROW
and DOWN ARROW keys or by clicking in a row, the details for the
current employee display in the bottom DataWindow control.

To accomplish this, you will add a script for the RowFocusChanged event
of the top DataWindow control (dw_master). That script will send a
retrieval request and the ID number of the selected employee to the bottom
DataWindow control (dw_detail).

RowFocusChanged also occurs upon DataWindow display

The RowFocusChanged event also occurs before the DataWindow is
displayed. This allows your application to retrieve and display detail
information for the first employee.
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Build a DataWindow script

182

1 Move the pointer to an unused area in the top DataWindow control and
right-click.

The popup menu for the DataWindow control displays.

Wi w_employees

Script..

Border

Change DataWindow..
Drag and Drop

Icon...

Modify DataWindow...
Name...

Style

Title...

Bring to Front

Send to Back

Clear
Duplicate

2  Select Script from the popup menu.

The PowerScript painter displays.

3 Click the down arrow next to the Select Event listbox and select
rowfocuschanged.

The title should read: Script - rowfocuschanged for dw_master.

= pt - rowfo anged for d

Select Event 4 aTte-Oby 31 Dacic Clot [

If the title is incorrect
If the object is not dw_master, select Edit>Select Object from the
menu bar and select dw_master.

4  Type the following script:

long empnum
long rownum

rownum = this.GetRow()
empnum = this.GetItemNumber (rownum, 2)

IF dw_detail.Retrieve(empnum) = 1 THEN
COMMIT using SQLCA;



Lesson 9 Adding the Second DataWindow

ELSE
ROLLBACK using SQLCA;
MessageBox("Retrieve","Retrieve error-detail")
END IF

Script - rowfocuschanged for dw_master

Select Event . Paste Object g Paste Global

long empnum
long rownum

rownum = this.GetRouw()
empnun = this.GetItemNumber(rownum, 2)

IF dw_detail.Retrieve(empnum) = 1 THEN
COMMIT using SQLCA;
ELSE
ROLLBACK using SQLCA;
MessageBox{"Retrieve”,"Retrieve error-detail™)
END IF|

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

PowerBuilder compiles the script. If there are errors, an error window
opens at the bottom of the screen. Correct your errors, then click the
Return icon again. You return to the Window painter.

PowerScript summary

long empnum

long rownum

The first two lines of this script declare local variables: empnum and
rownum. (These variables, which are both the long data type, could have
any names.)

rownum = this.GetRow()

The third line uses the GetRow function to determine the current row, as
determined by the user either clicking in it or scrolling to it via arrow or
tab keys. It stores the number of that row in the variable rownum. Also
note the use of the This keyword, which refers to the current object
(dw_master in this example).
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Build a DataWindow script

184

empnum = this.GetItemNumber (rownum, 2)

The fourth line uses the GetltemNumber function to obtain the number in
DataWindow dw_master that is in column 2 of the selected row. Since
column 2 has employee numbers in it, this function gets the employee
number for the current row. The employee number is stored in the variable
empnum.

IF dw_detail.Retrieve(empnum) = 1 THEN

COMMIT using SQLCA;
ELSE

ROLLBACK using SQLCA;

MessageBox ("Retrieve", "Retrieve error-detail"”)
END IF
This group of lines sends a retrieve request to DataWindow dw_detail
along with the argument the DataWindow expects (an employee number).
The IF statement that encloses the Retrieve function checks for successful
completion. If the function succeeds, it performs a database commit; if the
function fails, it performs a database rollback and displays a message box.

Production-level error checking

In a production application, you would also check SQLCA.SQLCODE
after the COMMIT and ROLLBACK statements to ensure that they
executed successfully.




Lesson 9 Adding the Second DataWindow

Extend the script for the Open event for the
window

Where you are
Lesson 9 Adding the Second DataWindow
Add the DataWindow control and object
Preview the window
Build a DataWindow script
= Extend the script for the Open event for the window
Run the application

You also need to tell the second DataWindow where to look for the
database variables (such as name and password). You can use the SQLCA
transaction object again.

As with the first DataWindow, you use the script for the open event for the
window to pass this information. You will extend the script you wrote
earlier for the Open event for your window.

1 Move the pointer to a blank area of your window and right-click.

The popup menu for the window displays.

Icon...
Pointer...

Paosition...

Style
Title...

Type

2 Select Script from the popup menu.
The PowerScript painter displays.
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Extend the script for the Open event for the window

3 Make sure the title reads: Script - open for w_employees

i
Select Event /41 Paste 0 p #1 Paste Instance

[FONNECT using SQLCA; 2
IF SQLCA.SQLCODE <> © THEN

MessageBox('Connect Error™,SQLCA.SQLERRTEXT)
HALT
END IF
dw_master .settransobject ( sqlca )
IF dw_master.Retrieve() = -1 THEN
ROLLBACK using SQLCA;
MessageBox(“Retrieve" ,"Retrieve failed")
ELSE
COMMIT using SQLCA;
dw_master .SetFocus()
dw_master .SetRowFocusIndicator(Hand?)
END IF

0001:0001

If the title is incorrect
If the object is not w_employees, select Edit>Select Object from
the menu bar and select w_employees.

If the event is not the Open event, click the Select Event listbox and
select Open.

You have already written a script for the Open event. Now you will
add to it.

4  Move the insertion point to the beginning of the line that reads /F
dw_master.Retrieve () = -1 THEN.
Press ENTER.
Press the UP ARROW.
Type this line:

dw_detail.settransobject ( sqlca )
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5

d dw_detail.settransebject ( sqlca

This line tells the second DataWindow to look in the SQLCA
transaction object for the values of the database variables.

Scriptf‘open for w_employees

Select Event E Paste Object E; Paste Global . Paste Instance Z

CONNECT using SQLCA;

IF SQLCA.SQLCODE <> @ THEN
MessageBox("'Connect Error",SQLCA.SQLERRTEXT)
HALT

END IF

dy

s

IF dw_mas - =

ROLLBACK using SQLCA;

MessageBox("Retrieve”,”Retrieve failed")
ELSE

COMMIT using SQLCA;

du_master .SetFocus()

dw_master .SetRowFocusIndicator(Hand?)
END IF

Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles the script and returns you to the Window
painter.
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Run the application

Run the application

Where you are

Lesson 9 Adding the Second DataWindow

Add the DataWindow control and object

Preview the window

Build a DataWindow script

Extend the script for the Open event for the window
= Run the application

1  Click the Run button in the PowerBar or the PainterBar.
or
Select File>Run from the menu bar.

PowerBuilder prompts you to save the current changes.

2 Click Yes.

Your window opens and displays the list of employees in the first
department and detail information for the first employee in the list.

Maintain Employees
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3  Click another employee ID.

The second DataWindow retrieves the details for the employee you
selected.

ntain Employees
i

4 Press PAGE DOWN to display the next department (depending on the size
of the dw_master DataWindow control, you may have to press Page
Down several times).

5 Click the Exit PictureButton.

You return to the Window painter.
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LESSON 10

Adding Database Maintenance
Functionality

A DataWindow can also easily handle inserting, updating, and deleting
rows in the database. In this lesson you will add PictureButtons for each of
these database functions. Then you will write short scripts to make the
buttons work.

When you finish this lesson and run your application, your application
window will look like this.

Maintain Employees

How long will this lesson take?
About 20 minutes.
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Add PictureButtons

Add PictureButtons

Where you are

Lesson 10 Adding Database Maintenance Functionality
= Add PictureButtons

Make the New PictureButton work

Make the Delete PictureButton work

Make the Save PictureButton work

Align and space the PictureButtons

Test the application

Debug if necessary

1 Atthis point you should be in the Window painter with w_employees
open.
If you are not, open the Window painter and select w_employees.
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2  Click the PictureButton button in the PainterBar.

3 Click near the right side of the first DataWindow, under the Exit
PictureButton.

A PictureButton displays where you clicked. The button is selected
(has a black box at each corner).

4  Select none in the text box at the top of the Window painter and press
DELETE.

This eliminates the text from the PictureButton.

5 Press CTRL+T.

PowerBuilder creates a duplicate of the selected control.

6 Press CTRL+T again.

PowerBuilder creates another duplicate.

You now have three PictureButtons arranged vertically at the right of your
window. Don't worry if the right-hand edge of the button is not visible. The
button size will be adjusted automatically when you add the picture in the
next step.
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Make the New PictureButton work

Make the New PictureButton work

Where you are
Lesson 10 Adding Database Maintenance Functionality
Add PictureButtons
= Make the New PictureButton work
Make the Delete PictureButton work
Make the Save PictureButton work
Align and space the PictureButtons
Test the application
Debug if necessary

The New PictureButton will insert an empty row in the second
DataWindow. You use this empty row to provide information for a new
employee.

In a few minutes you will make the Save PictureButton work. The Save
PictureButton is the button that actually adds the data in the new row to the
database.

| 1 Double-click the first of the three new PictureButtons.

The Select Picture dialog box displays.

“balbmp -
baby3.bmp
beach.bmp

blarrow.bmp
capb.bmp
capw.bmp
cascadel.bmp
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2

Double-click the filename tutnew.bmp.

The Select Picture dialog box closes and the PictureButton dialog box
displays with the 1 of pb_1 highlighted.

Type new
Select the Original Size checkbox.
Click the Script button.

Script
button

New replaces the highlighted 1 so the PictureButton control becomes
pb_new. The PowerScript painter displays.

Type the following script:

dw_detail.Reset ()
dw_detail.InsertRow (0)
dw_detail.SetFocus ()

The first line clears (resets) the DataWindow. The second line adds a
new row to the DataWindow. The third line positions the cursor in the
dw_detail control.

Script - clicked for pb_new _
[#]Paste Obiject [*][Paste Global

lSelel Event

dw_detail.Reset( )
du_detail.InsertRou( @)
dw_detail.SetFocus( )|
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Make the New PictureButton work

196

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

Your script compiles and you return to the Window painter. Your
window now has a PictureButton for adding new employees. This
PictureButton displays at its original size.
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Make the Delete PictureButton work

Where you are
Lesson 10 Adding Database Maintenance Functionality
Add PictureButtons
Make the New PictureButton work
= Make the Delete PictureButton work
Make the Save PictureButton work
Align and space the PictureButtons
Test the application
Debug if necessary

The Delete PictureButton will mark the row currently displayed in the
dw_detail DataWindow for deletion.

Double-click the second of the three new PictureButtons.

The Select Picture dialog box displays.

Double-click the filename tutdel.bmp.

The Select Picture dialog box closes and the PictureButton dialog box
displays with the 2 of pb_2 highlighted.

3 Type delete
Select the Original Size checkbox.
Click the Script button.

PictureButton

Delete replaces the highlighted 2 so the PictureButton control becomes
pb_delete. The PowerScript painter displays.
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Make the Delete PictureButton work

4  Type the following script:
dw_detail.DeleteRow (0)

The argument 0 in the DeleteRow function specifies that the current
row in the dw_detail control is to be deleted. This does not delete the
row from the dw_master DataWindow control. You could add lines to
the script that perform dw_master DeleteRow processing.

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

Your script compiles and you return to the Window painter. Your
window now has a Delete PictureButton for deleting employees.
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Make the Save PictureButton work

Where you are
Lesson 10 Adding Database Maintenance Functionality
Add PictureButtons
Make the New PictureButton work
Make the Delete PictureButton work
= Make the Save PictureButton work
Align and space the PictureButtons
Test the application
Debug if necessary

In the tutor_pb application, the changes you make in the DataWindow are
not automatically applied to the database. The Save PictureButton will
issue the Update function to apply your changes to the database:

¢ If you have just added a new employee using the New PictureButton,
the Save PictureButton will add the new row to the database.

¢ If you have just deleted an employee using the Delete PictureButton,
the Save PictureButton will delete the row from the database.

¢ If you have just changed employee information, the Save
PictureButton will apply the changes to the database.

Double-click the third PictureButton.
The Select Picture dialog box displays again.

Double-click the filename tutsave.bmp.

The Select Picture dialog box closes and the PictureButton dialog box
displays.
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Make the Save PictureButton work

200

3

Type save
Select the Original Size checkbox.
Click the Script button.

Save replaces the highlighted 3 so the PictureButton control becomes
pb_save. The PowerScript painter displays.

Type the following script:

IF dw_detail.Update () = 1 THEN
COMMIT using SQLCA;
MessageBox( "Save", "Save succeeded")
ELSE
ROLLBACK using SQLCA;
MessageBox("Save", "Save failed")
END IF

The first line updates the database with all changes to the dw_detail
DataWindow. If the update succeeds, it performs a database commit
and displays a success message. If the update fails, it performs a
database rollback and displays a failure message.

~ Script - clicked for pl

[#]Paste Obiect [#]Paste Global

Select Event

IF dw_detail.Update () = 1 THEN
COMMIT using SQLCA;
MessageBox("Save","Save succeeded")
E

ROLLBACK using SQLCA;
HessageBox(“'Save","Save failed")
END IF
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Click the Return button in the PainterBar.
or

Select File> Return from the menu bar.

Your script compiles and you return to the Window painter. Your
window now has a Save PictureButton for applying changes to the
database.

6 Select File>Save from the menu bar.

This saves your changes before modifying PictureButton alignment
and spacing.
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Align and space the PictureButtons

Align and space the PictureButtons

202

Where you are
Lesson 10 Adding Database Maintenance Functionality
Add PictureButtons
Make the New PictureButton work
Make the Delete PictureButton work
Make the Save PictureButton work
=» Align and space the PictureButtons
Test the application
Debug if necessary

Now you will align the PictureButtons and space them evenly.

1  Use the cTRL+click method to select all four PictureButtons.

Using the CTRL+click selection method gives you control over which
button determines alignment, sizing, and spacing.

¢ Alignment and sizing PowerBuilder uses the first button you
select to align and size the remaining buttons.

¢ Spacing PowerBuilder uses the first two buttons you select to
adjust the spacing of the remaining buttons.

2  Select Edit>Align Controls from the menu bar.

The align options display.
3 Click the option (left, right, or middle) that represents the way you want
to align the PictureButtons.

PowerBuilder adjusts the alignment.

4 Select Edit>Space Controls from the menu bar.

5 Click the option that adjusts space vertically.

PowerBuilder adjusts the space between the PictureButtons.
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Your window should look something like this now.
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Test the application

Test the application

Where you are
Lesson 10 Adding Database Maintenance Functionality
Add PictureButtons
Make the New PictureButton work
Make the Delete PictureButton work
Make the Save PictureButton work
Align and space the PictureButtons
= Test the application
Debug if necessary

1  Click the Run button in the PowerBar.
or
Select File>Run from the menu bar.

PowerBuilder prompts you to confirm that you want to save the current
changes.

2 Click Yes.

Your application runs.
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Click the New PictureButton.

A new blank form displays in the lower DataWindow. Notice that the
Status is Active as you requested for Initial Value in the database
extended attribute information.

Maintain Employees

Click the Employee ID box.

Add an employee ID, department number, name, and salary for the new
employee. ‘
Use the TAB key to move from box to box.

Click the Save PictureButton.

This sends the new employee data to the database and displays a
confirmation message, as coded in the pb_save script.

In this tutorial, the new employee does not display in the top
DataWindow. (You could code the script to include this feature.)

Click an employee in the top DataWindow.

That employee's data displays in the lower DataWindow.

Change the employee's salary.

Click the Save PictureButton.

This sends the revised employee data to the database and displays a

confirmation message, as coded in the pb_save script.
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Test the application

You could program this update to occur automatically.

10 Select another employee in the top DataWindow.

That employee's data displays in the bottom DataWindow.

Click the Delete PictureButton.

The employee is deleted from the DataWindow immediately but will
not be deleted from the database until you click the Save button.

Again, you could program this update to occur automatically.

Click the Exit PictureButton.

You return to the Window painter.

File Edit Controls Design Declare Options

13 Select File> Close from the menu bar.
You return to the Window painter.

You now have a complete application for viewing, adding, changing, and
deleting employee data.
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Debug if necessary

Where you are
Lesson 10 Adding Database Maintenance Functionality
Add PictureButtons
Make the New PictureButton work
Make the Delete PictureButton work
Make the Save PictureButton work
Align and the space PictureButtons
Test the application
» Debug if necessary

Your application should run without errors. However, if an error occurs,
you can use Debug to find it.

& For information about Debug, see the User's Guide.
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LESSON 11

Adding a Menu

In this lesson you will create a menu and add it to your window. Although

you are creating the menu last in this tutorial, you could create it at any
time.

Menus are separate objects that you create using the Menu painter. After
you create a menu, you can attach it to as many windows as you want.

When you finish this lesson, your application window will have a menu
bar. It will look like this during execution.

[N Employee Help
Save Ctrl+S

Print Detail  Ctrl+P
Printer Setup

Maintain Employees %

How long will this lesson take?
About 25 minutes.
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Open the Menu painter

Open the Menu painter

Where you are

Lesson 11 _Adding a Menu
= Open the Menu painter

Add menu items

Add scripts

Save the menu

Add more menu items

Add more scripts

Add the menu to the window

Test the menu

Click the Menu painter button in the PowerBar.

The Select Menu dialog box displays.

c:\pb4\tutor_pb.pbi
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2  Click the New button to create a new menu.

The Menu painter workspace displays.

In the Menu painter, you build menus the way they will look when they're
done. That is, you put the menu bar items across the top of the painter, and
you build the menu for each menu bar item in a list underneath.
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Add menu items

Add menu items

Where you are
Lesson 11 _Adding a Menu
Open the Menu painter
= Add menu items
Add scripts
Save the menu
Add more menu items
Add more scripts
Add the menu to the window
Test the menu

When you first open the Menu painter workspace, the insertion point is
positioned at the first item in the menu bar.

1 Type &File
Press TAB.

The insertion point moves to the first menu item under Menu For.

The ampersand character defines accelerator keys

The & (ampersand) is the standard for defining accelerator keys,
which provide mnemonic access to menus and window controls. In
the tutor_pb application, for example, the user can access the File
menu by pressing ALT+F.

212



Lesson 11 Adding a Menu

2 Type &Save
Type Sin the Shortcut Key field.
Select the Ctrl checkbox.
Press TAB.

This establishes a Save menu item under the File menu. S is the
accelerator key, CTRL+S is the shortcut key, and m_save is the menu
item name (you use this name to reference the menu item in scripts).

The pointer moves to the second menu item under File.

3 Type - (hyphen)
Press TAB.

The hyphen creates a separator line that spans the width of the menu
and m_- is the menu item name.

4  Type &Print Detail
Type Pin the Shortcut Key field.
Select the Ctrl checkbox.
Press TAB.

This establishes a Print Detail menu item. P is the accelerator key,
CTRL+P is the shortcut key, and m_printdetail is the menu item name.

5 Type Pé&rinter Setup...
Press TAB.

This establishes a Printer Setup menu item. R is the accelerator key
and m_printersetup is the menu item name.
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Add menu items

214

Using ellipsis points
By convention, ellipsis points (...) following a menu item indicates
that clicking the item will display a dialog box.

Type another - (hyphen)
Press TAB.

This establishes another separator line with a default menu item name
of m_-, which is a duplicate of the automatically generated menu item
name for the first hyphen. Duplicate menu item names are not allowed
and the Invalid Menu Item Name dialog box displays, suggesting an
alternative menu item name.

& For more information on duplicate menu item names, see the
User's Guide.

Click OKto accept the suggested alternative name and close the dialog
box.

Type Eé&xit
Select F4in the Shortcut Key dropdown listbox.
Select the Alt checkbox.

This establishes an Exit menu item. X is the accelerator key, ALT+F4 is
the shortcut key, and m_exit is the menu item name.




Lesson 11 Adding a Menu

Add scripts

Where you are
Lesson 11 Adding a Menu
Open the Menu painter
Add menu items
= Add scripts
Save the menu
Add more menu items
Add more scripts
Add the menu to the window
Test the menu

Now you will add scripts for the Clicked events associated with each of the
menu items you just defined. When the application executes and the user
selects one of these menu items, PowerBuilder executes the associated
script.

1 Click in the Save box under the File menu that you added.

Click the Script button in the PainterBar.

The PowerScript painter displays.

3  Type the following script:

w_employees.pb_save.TriggerEvent(Clicked!)

This triggers the Clicked event for the Save PictureButton in the
w_employees window. That is, selecting File>Save is the same as
clicking the Save PictureButton. You could just as easily have entered
script to update the dw_detail DataWindow, but then you would have
to maintain script (including all the error checking) in two places
(pb_save and the Save menu item).
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Add scripts

216

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

Your script compiles and you return to the Menu painter.

Click the Print Detail box.
Click the Script button in the PainterBar.
Type the following script:

w_employees.dw_detail.Print ()

This uses the Print function to print the detail information for the
current employee.

Click the Return button in the PainterBar.
or
Select File>Return from the menu bar.

Click the Printer Setup box.
Click the Script button in the PainterBar.
Type the following script:

PrintSetup ()

This uses the PrintSetup function to display the standard Print Setup
dialog box.

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

Click the Exit box.
Click the Script button in the PainterBar.
Type the following script:

Close(ParentWindow)

About the ParentWindow keyword
The reserved word ParentWindow is used only in menu scripts and
means the window to which the menu is attached.




Lesson 11 Adding a Menu

10 Click the Return button in the PainterBar.
or

Select File>Return from the menu bar.

217



Save the menu

Save the menu

218

Where you are
Lesson 11 _Adding a Menu
Open the Menu painter
Add menu items
Add scripts
= Save the menu
Add more menu items
Add more scripts
Add the menu to the window
Test the menu

Select File>Save from the menu bar.

The Save Menu dialog box opens.

Application Libtaies:
| c:\pb4\tutor_pb.pbl

The insertion point is in the Menus box.

Type m_employees as the name of the new menu.
Type a comment in the Comments box.
Click OK.

The name you just assigned to the menu displays in the title bar of the
Menu painter workspace.
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Add more menu items

Where you are
Lesson 11 Adding a Menu
Open the Menu painter
Add menu items
Add scripts
Save the menu
= Add more menu items
Add more scripts
Add the menu to the window
Test the menu

1 Click just to the right of the File menu bar item that you added earlier in
this lesson.

A new empty box displays.

2 Type &Employee
Press TAB.

The insertion point moves to the first menu item under Employee.

3 Type &Add New
Press TAB.

The insertion point moves to the second menu item under Employee.

4  Type &Delete
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Add more menu items
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Click just to the right of the Employee menu item.

Another empty box displays.

Type &Help
Press TAB.

The insertion point moves to the first menu item under Help.

Type &Contents
Select F1in the Shortcut Key dropdown listbox.

Select Design>Preview from the menu bar.

PowerBuilder displays your menu at the top of an empty sample
window. You can select items from this menu to confirm its design.
For example, if you click on the File menu, you should see this:

m_employees

Print Detail  Ctrl+P
Printer Setup

Exit Alt+F4

Select Design>Preview from the menu bar again.

The Menu painter workspace displays.
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Add more scripts

Where you are
Lesson 11 _Adding a Menu
Open the Menu painter
Add menu items
Add scripts
Save the menu
Add more menu items
= Add more scripts
Add the menu to the window
Test the menu

Now you will add script for menu items added in the previous step.
1 Click the Employee box.
2 Click the Add New box.

Click the Script button in the PainterBar.

The PowerScript painter displays.

4 Type the following script:

w_employees.pb_new.TriggerEvent(Clicked!)

This triggers the Clicked event for the New PictureButton in the
w_employees window. That is, selecting Employee> Add New is the
same as clicking the New PictureButton.

Click the Return button in the PainterBar.
or
Select File>Return from the menu bar.

Your script compiles and you return to the Menu painter.

6 Click the Delete box.
Click the Script button in the PainterBar.
Type the following script:

w_employees.pb_delete.TriggerEvent(Clicked!)
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Add more scripts
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10

11

This triggers the Clicked event for the Delete PictureButton in the
w_employees window. That is, selecting Employee> Delete is the
same as clicking the Delete PictureButton.

Click the Return button in the PainterBar.
or
Select File>Return from the menu bar.

Click the Help box.

Click the Contents box.
Click the Script button in the PainterBar.
Type the following script:

ShowHelp ("tutor_pb.hlp",Index!)

This opens the tutor_pb.hlp windows Help file.

Tutor_pb.hlp must be accessible

The tutor_pb.hlp file, which is delivered with PowerBuilder
Version 4.0 and installed in the same directory as the other tutorial
files, should be in a directory that is on your Path. If not, you must
modify the ShowHelp function with the fully qualified name of the
directory containing the tutor_pb.hlp file.

Select File>Close from the menu bar.

PowerBuilder prompts you to save your changes.

Click Yes.
The Menu painter closes.

You now have a complete menu that is ready to be associated with a
window.
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Add the menu to the window

Where you are
Lesson 11 Adding a Menu
Open the Menu painter
Add menu items
Add scripts
Save the menu
Add more menu items
Add more scripts
= Add the menu to the window
Test the menu

1 Click the Window painter button in the PowerBar.

The Window painter opens and the Select Window dialog box
displays.

2 Select w_employees and click OK.

Your window displays in the workspace.

3 Select Design>Window Style from the menu bar.

The Window Style dialog box displays.

4  Select the Menu checkbox.

Window Style

File Edit Help

|AppWorkSpace

Since there is only one menu in this application, the menu you just
created, m_employees, displays in the listbox.
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Add the menu to the window

224

If there were more menus, you could click the down arrow next to the
menu name to see all the menus in this application.

When you checked the Menu checkbox, PowerBuilder displayed a
menu in the sample window on the right. This menu is not the menu
you just created; it is a generic menu to indicate you want a menu on
this window.

Click OK.

The Window painter workspace displays.
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Test the menu

Where you are

Lesson 11 Adding a Menu

Open the Menu painter

Add menu items

Add scripts

Save the menu

Add more menu items

Add more scripts

Add the menu to the window
= Test the menu

1  Click the Run button.
or
Select File>Run from the menu bar.

PowerBuilder prompts to confirm that you want to save the current
changes and run your application.

2 Click Yes.

Your application runs. The window opens and displays a menu bar
across the top.

il
File Employee Help

Maintain Employees
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Test the menu
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3

If your window doesn't look right

Adding a menu moves all the objects in the window down. As a
result, the second DataWindow in your window may be partially off
the bottom. If this happens, return to the Window painter and
enlarge the window size.

Click the Help menu.

The Contents menu item drops down.

B

Click Contents.
The Windows Help system opens displaying the tutor_pb.hlp Help file.

i
File Edit Bookmark Help

This online help file is called by the PowerBuilder Getting Started tutorial
application (tutor_pb). It contains brief information about the application and
descriptions of the application's windows, DataWindows, and menu.

For complete tutorial application information, see the Getting Started manual.
Overview

Using the Tutor_pb application

Tutor_ph DataWindows, controls, and scripts

Press ALT+F4,

The Maintain Employees window displays.

Click the Employee menu.
The Add New and Delete menu items drop down.

Employee
Add New



Adding a Menu

7  Click the File menu.

The Save, Print Detail, Printer Setup, and Exit menu items drop down.

Employee Help

Print Detail
Printer Setup

Ctri+P

Exit

Alt+F4

8 Test other menu items.

Your application should run without errors. However, if an error
occurs, you can use Debug to find it.

& For information about Debug, see the User's Guide.

9  Select File>Exit from the menu bar.

The script you wrote for this menu item [Close(ParentWindow)] runs.

Your application closes and you return to the Window painter.
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LESSON 12
Using Inheritance to Build a Window

In your applications, you will often have many windows that look similar
and perform the same or similar activities. When this occurs, you will want
the windows to have a standard look and you will not want to recode the
scripts each time you create one of these windows. To do this, you can use
inheritance.

In this lesson you will use inheritance to build a descendent window that
looks like the window you just built (the ancestor) but limits the user's
access. The descendent window will inherit its events, attributes, and
scripts from the ancestor. You will modify it so it is a display-only window
rather than an updatable window.

When you finish this lesson, the new application window will look like
this.

No buttons for
updating the
database

How long will this lesson take?
About 10 minutes.
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Create the descendent window

Create the descendent window

Where you are

Lesson 12 Using Inheritance to Build a Window
= Create the descendent window

Modify the descendent window

Modify the application to display the window

Test the application

1 You should be in the Window painter.
Select File>Open from the menu bar.

The Select Window dialog box displays. It includes an Inherit button.

Main window for PowerBuilder 4.0 tutor_pb
application

¢ sm c:\pb4\tutor_pb_pbl
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Lesson 12 Using Inheritance to Build a Window

Click the Inherit button.

The Inherit From Window dialog box displays. You use this to build a
window that inherits its appearance and scripts from an existing
window.

Inherit From Window

Main window for P Builder 4.0 tutor_pb

Select w_employees and click OK.

The Window painter workspace opens and a new (Untitled) window
inherited from the w_employees window displays.
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Modify the descendent window

Modify the descendent window

232

Where you are
Lesson 12 Using Inheritance to Build a Window
Create the descendent window

= Modify the descendent window
Modify the application to display the window
Test the application

You want to create a display-only window, so you do not want the user to
see the bottom three PictureButtons. However, you cannot delete controls
in a descendent window, so you will have to make them invisible. You will
also remove the menu.

PictureButton

\pb4\tutnew_bmp
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Click OK.

The PictureButton is no longer visible or active.

The button is no longer visible

erited from

Repeat steps 1-3 for the Delete and Save PictureButtons.

Select Design>Window Style from the menu bar.

The Window Style dialog box displays.

Deselect the Menu checkbox.

Window Style

Maintain Employees
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Modify the descendent window

234

10

Click OK.

Select File>Close from the menu bar.

A dialog box displays asking if you want to save changes.

Click Yes.
The Save Window dialog box displays.

Type w_emp_display in the Name box.
Enter a comment in the Comments box.
Then click OK.

PowerBuilder saves your new window as a descendant of
w_employees, closes the Window painter, and displays the PowerBar.

You can now reference your new window in scripts and create
descendent objects that inherit their attributes, events, and scripts from
this window.
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Modify the application to display the window

Where you are
Lesson 12 Using Inheritance to Build a Window
Create the descendent window
Modify the descendent window

= Modify the application to display the window
Test the application

In a real application, you would probably check the user's ID and based on
the user's level of access, display the appropriate window. But to keep it
simple, in this tutorial you will just modify the script for the application
Open event to display the descendent window.

Open the Application painter by clicking the Application button in the
PowerBar.

The Application painter workspace displays.

Click the Script button in the PainterBar.

The PowerScript painter workspace displays. The title should read:
Script - open for tutor_pb.

If the event is incorrect
If the PowerScript painter displays an event other than Open, click
on the down arrow next to the Select Event listbox and select Open.

3 Select the window name w_employees in the last line of the script and
type:

w_emp_display

Script - open for tutor_pb

Select Event [#]Paste Dbject [#]Paste Global

SQLCA.DBMS=ProfileString &
("PB.INI","Database”,"DBHS"," *)

i =

SQLCA.DbParm=ProfileString &
“pR " “Database,"DbParm”," )

<

open (w_emp_display)

Now your script will display the new descendent window instead of the
original window you created.
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Modify the application to display the window

4  Click the Return button.
or
Select File> Return from the menu bar.

Your script compiles and you return to the Application painter
workspace.

5 Select File>Save from the menu bar.

PowerBuilder saves your Application object with the revised Open
script.
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Lesson 12  Using Inheritance to Build a Window

Test the application

No menu bar

Where you are
Lesson 12 Using Inheritance to Build a Window
Create the descendent window
Modify the descendent window
Modify the application to display the window
= Test the application

In this section you will test the finished application to be sure there are no
errors before you build an executable file.

To test the application, click the Run button in the PowerBar.
or
Select File>Run from the menu bar.

You can display data but you cannot insert rows, delete rows, or
update the database.

No buttons fc
updating the
database

There should not be any errors. But if there are, you can use Debug to
find them.

Now before going on, you will restore the original window name in the
script for the application Open event.

Click the Exit PictureButton to close the application.

You return to the Application painter.
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Test the application

3

238

Click the Script button in the PainterBar.

The PowerScript painter workspace displays the current script for the
application Open event.

Select the window name w_emp_display in the last line of the script and
type:

w_employees

= p ope 0 or_pb

Select Event 41 Paste Dbject & Paste Global

SQLCA.DBMS=ProfileString &
("PB.INI","Database™,"DBHS"," ")

SQLCA.DbParm=ProfileString &
("PB.INI","Database', DbParm"," ")

< open (w_employees)

Now your script will open the original window you created.

Click the Return button in the PainterBar.
or
Select File>Return from the menu bar.

Your script compiles and you return to the Application painter
workspace.

To make sure your application is working correctly before creating the
EXE, click the Run button in the PowerBar.

or

Select File>Run from the menu bar.

Then click Yes to save your changes.

Your original application should run.

Click the Exit PictureButton to close the application.

You return to the Application painter.



LESSON 13

Creating the EXE File for the Application

When you finish an application, you can create an executable version of it
for distribution to your users.

The users can run this executable version of your application from the
Windows Program Manager like any other Windows application (such as
Microsoft Excel or Word for Windows).

How long will this lesson take?
About 10 minutes.
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Create the EXE file

Create the EXE file

Where you are

Lesson 13 Creating the EXE File for the Application
= Create the EXE file

Test the EXE file

1 Make sure you are in the Application painter and all other painters are
closed.

Click the Create Exe button in the PainterBar (if you're using PowerTips,
the text is Create Executable).

If you haven't saved since modifying the Application Open event, a
dialog box displays. If so, click Yes to save changes.

The Select Executable File dialog box displays. The default name for
the executable file is the name of the application plus the EXE
extension (in this case, tutor_pb.exe).

_Select Executable File

xecutable Files '['.exe]

About the EXE filename

If your application name has more than eight characters,
PowerBuilder truncates it for the default EXE filename. You can
choose any one- to eight-character name you want.

The default location is the directory in which you are working.

240



Lesson 13 Creating the EXE File for the Application

3 Click OK.
The Create Executable dialog box displays.

About the Dynamic Libraries box
Do not select anything in the Dynamic Libraries box at the bottom
of the screen.

& For complete information about EXE creation, including the
Project painter and dynamic libraries, see the User's Guide.

4 Click OK.

PowerBuilder creates an EXE file that contains definitions for the
objects (such as windows, menus, and DataWindows) in your
application, the bitmap files used in your PictureButtons, the
application icon, and the compiled scripts. It does not contain any
source code.

After creating the EXE file, PowerBuilder returns you to the
Application painter workspace.
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Test the EXE file

Test the EXE file

Where you are
Lesson 13 Creating the EXE File for the Application
Create the EXE file

= Test the EXE file

Now you are ready to test your new EXE file.

Running from another PC
To run your application from another PC, you need a copy of the
Database Development and Deployment Kit.

1 Click the down arrow in the upper-right corner of PowerBuilder to
minimize PowerBuilder.

PowerBuilder collapses to an icon at the bottom of your screen.
2 Open the Windows Program Manager.
If necessary, double-click the Program Manager icon at the bottom of

your screen.

3 Select the program group where you want the application icon.

Program Manager

e prr— - e Z
74
53 =

File Manager Control Panel Print Manager

)

7 =
Windows
Setup

Cardfile Calendar Calculator

[

Program group @y
Dbict Character Map |

Packager

Notepad SysEdit
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Lesson 13 Creating the EXE File for the Application

4  Select File>New from the Program Manager menu bar.

The New Program Object dialog box displays. Program Item, which
you want, is the default.

" New Program Object.

New
O Program Group

(C]

5 Click OK.
The Program Item Properties dialog box displays.

6 Type the description Maintain Employees

7  Enter the fully qualified path to the EXE file in the Command Line box.
For example: c:\pb4\tutor_pb.exe

Program ltem Properties

Description: Maintain Employees
Command Line: c:\pb4\tutor_pb.exe|
Working Directory:

Shortcut Key: LNone

[ Run Minimized

8 Click OK.

The Tutor_pb icon and description display in the selected program
group in the Program Manager.

7 =
m &

File Manager Control anel Print Manager

Cardfile Calendar Calculator Clock

Object Character Map |
Packager i

Notepad SysEdit

Maintain
Employees
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Test the EXE file

9  Double-click the icon for the Maintain Employees application.
Your application runs.

You can browse through employees, select them, and update
information. You can also add new employees, change data, and make
deletions.

Maintain Employees

Click the Exit PictureButton.

You return to Windows Program Manager or desktop.

11 Double-click the PowerBuilder icon at the bottom of your screen.
You return to PowerBuilder.

The EXE file is a compact, fully functional version of your application,
ready to deliver to users.

What to do next
You should continue with the Building Applications manual.

Additionally, look at the roadmap at the beginning of this manual. The
roadmap is a guide to all the resources available as you learn to use
PowerBuilder.
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APPENDIX
Tutorial Application Review

This appendix contains graphic representations of the tutor_pb application
and its components. Use this information to review the objects, concepts,
and organization of the tutor_pb application.

245



Application architecture

Application architecture
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Application

tutor_pb

w_employees

d_emplist

DataWindow

d_employee

DataWindow

m_employees

pb_new
pb_delete

|

| ]

‘ PictureButtons
| pb_save
|

w_emp_display (read-only descendant
of w_employees)

Window




Appendix

Tutorial Application Review

Code map

Application

Window

tutor_pb

Application

Event
Script

Open

Set SQLCA values and open
the w_logon window

Event
Script

Close

Disconnect from the
database

w_employees

Window
\

( Open ( | pb_new.Clicked h
| Event | Connect to database, set | Event | Insert a new row in

Script| TransObject, and retrieve Ecript:dw detail
| rows from the database —
N

| dw_master. (E™ | pb_delete.Clicked R

| RowFocusChanged i

Event | Retrieve information for | Event | Deletes a row from

Script l dw_detail z\Script dw_detail
TN - : ~
| pb_exit.Clicked | pb_save.Clicked
| Event‘ ) o ( Event
Gcript ‘ Exit the application *@cript Update the database
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Code map

Menu

248

m_employees

Event
Script

m_file.m_save.Clicked

Trigger w_employee.
pb_save.Clicked

m_tfile.m_printdetail.

Clicked
Print dw_detail

[ m_file.m_printersetup.

Clicked
Display Windows Print
Setup dialog box

| m_file.m_exit.Clicked

Exit the application

Event
Script
N P!

m_employee.m_addnew.
Clicked

Trigger w_employee.
pb_new.Clicked

/‘
Event

Script
> p

m_employee.m_delete.
Clicked

Trigger w_employee.
pb_delete.Clicked

"I m_help.m_contents.

Clicked
Display tutor_pb.hip Help
file




Index

A

accelerator keys 212 see also shortcut keys
align options 202
ampersand (&)
accelerator key 212
continuation character 144
ancestor, window 229
application
architecture 246
code map 247
debugging 207
EXE file 239
overview 245
running 92, 101
testing 204
application object
creating 22
current 26
icon 32,243
modifying Open event for descendent window
235
Open event 89, 143
Application painter
Application dialog box 25
application object 23
Close event 145
Create EXE 240
Create Executable dialog box 241
Open event 89
Save Application dialog box 25
Select Executable File dialog box 240
Select Icon dialog box 32
Select New Application Library dialog box
24
attributes, DataWindow control 131

background color
DataWindow object 122

background color (continued)
Default to 3D option 75

bands see DataWindow painter

bitmaps see also PictureButton
choosing for PictureButton 79, 194, 197, 199
tutorial 19

border style, DataWindow 171

C

Clicked event
exit PictureButton 83
menu items 215
Close event
application 145
Close function 85, 216
code examples, using 7
code map 247
color, DataWindow object 122
ColorBar, placement and display 27
columns
changing border style in DataWindow 171
changing edit style in DataWindow 168
creating 38
defining 41
display format 61
extended attributes 50
initial value 55
NOT NULL specification 41
primary key 43
rearranging on DataWindow 165
validation rule 57
command line 3
CommandButton see also PictureButton
comparison with PictureButtons 77
comments
DataWindow 112, 163
menu 218
PowerScript 149
window 87, 234
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COMMIT statement 139, 146, 182, 200
CONNECT statement 140
context-sensitive online Help 6, 85
continuation character 144
control

deleting 80

duplicating 193
Control Panel, currency format 62
currency format 62
current application 26

D

Data Manipulation window 68
data source
Quick Select 105
SQL Select 153
data types, defining for database columns 41
database see also repository
adding arow 195
column definition 41
creating 36
deleting a row 198
extended attributes 50
ODBC.INI file 37
PB.INI file 37
primary key 43
setting transaction object 139
table creation 38
table population 65
transaction object 133
updating 199
updating through a DataWindow control 200
Database Administration window 65
database management system (DBMS) 38. see
also database
Database painter
Alter Table dialog box 52, 55
closing tables 47
Column Display Format dialog box 61
Column Validation dialog box 57
Create Local Database dialog box 36
Create Table dialog box 39
Data Manipulation window 68
Database Administration window 65
Display Format Definition dialog box 61
File Import dialog box 66
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Database painter (continued)

Input Validation dialog box 58

opening 34

opening tables 47

popup menu 46

Primary Key Definition dialog box 43

Select Tables dialog box 34, 47
DataWindow control

adding 126, 176

adding arow 195

attributes 131

DataWindow object 130

deleting arow 198

ItemError event 71

popup menu 182

retrieving data 139, 182

RowFocusChanged event 182

setting transaction object 139

updating the database 200
DataWindow object

changing border style 171

changing edit style 168

creating 153

d_emplist 103

data source 105

display order 106

enhancing 164

extended attributes 50

group 114

initial value usage 56

presentation style 105

preview 110, 117, 121, 161, 173

rearranging columns 165

retrieval argument 157

saving 112,163

selecting columns with Quick Select 106

selecting in DataWindow control 130

WHERE clause 158
DataWindow painter

bands 109

buffering retrieved rows 111

changing border style 171

changing edit style 168

detail band 109

footer band 109

group 114

group band 117

header band 109



DataWindow painter (continued)
New DataWindow dialog box 105, 153
overriding validation rule message 71
preview 110, 117, 121, 161, 173
Quick Select dialog box 105
RadionButton Style dialog box 168
retrieval argument 157
Save DataWindow dialog box 112, 163
Select DataWindow dialog box 104, 153
Specify Group Columns dialog box 115
Specify Retrieval Arguments dialog box 157
summary band 109
WHERE clause 158

DBMS 38. see also database

DBMS parameter 144

Dbparm parameter 144

debugging 207

Default to 3D option 75

delete PictureButton 197

DeleteRow function 198

descendent window
creating 230
hiding PictureButton controls 232
running 237
saving 234

detail band 109

DISCONNECT statement
application Close event 146
COMMIT note 146

display format, specifying extended attribute 61

E

edit style
changing in DataWindow 168
radio button 168
ellipsis points 214
emp_tutorial table, creation 40
enumerated variable 140
examples, code 7
EXE file
application icon 32
creating 239
testing 242
executable file see EXE file
exit PictureButton
Clicked event 83

exit PictureButton (continued)
defining 77
extended attributes
about 50
Data Manipulation window example 69
display format 61
headers 52
initial value 55
labels 52
validation rule 57

F

files 19
floating toolbar 28
footer band 109
freeform presentation style
column note 164
DataWindow definition 154
functions
code examples 12
context-sensitive online Help 6, 85

G

GetltemNumber function 182
GetRow function 182
group
band 117
creating 115
DataWindow 114
header 118

H

header band 109
headers, defining 52
Help see online Help
help button 39

help menu, adding 220

icon
application 32, 243
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icon (continued)
tutorial 19
inheritance 229

initial value, specifying extended attribute 55

InsertRow function 195
ItemError event, overriding validation rule
message 71

K

keyword
ParentWindow 216
This 183

L

labels, defining 52

lasso select 166

Library painter, comments 112
local database see database

Master/Detail application 181
menu
associating with a window 223
creating 209
menu items 212
saving 218
scripts for menu items 215
testing 225
menu items
Clicked event 215
defining 212
ellipsis points 214
Menu painter
accelerator keys 212
Invalid Menu Name dialog box 214
menu items 212
opening 210
ParentWindow keyword 216
Save Menu dialog box 218
scripts 215
Select Menu dialog box 210
MessageBox function 139, 146, 182, 200
multiple items, selecting 119, 166
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N

new PictureButton 194

(o)

Object browser 134

ODBC.INIfile 37

online Help
context-sensitive for functions 6, 85
Create Table dialog box 39
ShowHelp function 222
tutor_pb.hlp file 19
tutorial example 226
using 5

Open event
application 89
application object 235, 238
window 134, 185

Open function 90

P

PainterBar
button text vs. PowerTips 78
placement and display 27
popup menu 28
PowerScript painter actions 84
painters, opening and closing 88
parent reserved word 85
ParentWindow keyword 216
PB.INI file 37
PBL, creating 25
PictureButton
aligning 202
attribute values 81
Clicked event (Exit button) 83
defining 77, 192
delete 197
exit 77
hiding in descendent window 232
naming 82
new 194
save 199
script for exit 83
spacing 202



popup menu
DataWindow control 182
PainterBar 28
window 98, 135, 185
PowerBar, placement and display 27
PowerBuilder library, creating 25
PowerBuilder preferences file see PB.INI file
PowerBuilder, starting 2
PowerPanel see PowerBar
PowerScript painter
Application painter 143, 145
comments 149
compiling a script 86
continuation character 144
error window 86
list of actions 84
Menu painter 215
ParentWindow keyword 216
Window painter 135, 182, 185, 195
Powersoft Demo DB 7
PowerTips
about 27
instead of showing button text 78
presentation style
d_emplist DataWindow object 105
freeform 154
preview
DataWindow 121
DataWindow object 110, 161, 173
window 180
primary key, creating 43
Print function 216
PrintSetup function 216
ProfileString function 144
program group, selecting 242
program item, creating 243
Program Manager 242
prototype parameter 138

Q

quick select
sort criteria 107
using 105

R

radio button edit style 168
repository  see also database
Data Manipulation window example 69
default initial value 56
display format 63
extended attributes 50
headers 54
headers used in DataWindow 108
labels 54
validation rule 60
reserved word  see keyword
Reset function 195
retrieval argument
Arguments dialog box 159
creating 157
WHERE clause 158
Retrieve function 139, 182
right mouse button 28
ROLLBACK statement 139, 146, 182, 200
RowFocusChanged event 181, 182

S

sample applications 7
save PictureButton 199
save versus save as 87
script
comments 149
compiling 86
continuation character 144
DataWindow control RowFocusChanged event
182
error window 86
window Open event 134
Select painter
Arguments dialog box 159
tab area 156
Select painter, about 155
selecting multiple items 119, 166
SetFocus function 139, 195
SetRowFocusIndicator function 139
SetTransObject function

coding 186
prototype parameter 138
setup 19
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SHIFT+F1, context-sensitive online Help for
functions 6, 85
shortcut keys 213
ShowHelp function 222
spacing options 202
SQL
batch file with INSERT statements 66
SQL painter 154
SQL Select 153
SQL statements 19
SQL syntax, Select painter 156
SQLCA
about 133

checking SQLCODE after CONNECT 140

checking SQLCODE after DISCONNECT
146

CONNECT statement 140

DBMS parameter 144

Dbparm parameter 144

DISCONNECT statement 146

initializing 142

SetTransObject function 139, 186
SQLCODE

checking after CONNECT 140

checking after DISCONNECT 146
starting PowerBuilder 2
StyleBar, placement and display 27
summary band 109

T

tab area 156
table
adding data 65
closing in the Database Painter 47
creating 38
extended attributes 50
naming 40
opening in the Database Painter 47
popup menu 46
primary key 43
requesting creation 45
tabular presentation style 105
This keyword 183
toolbar
controlling 27
customizing 29
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toolbar (continued)

dragging 28

floating 28

Toolbar dialog box 30
transaction object

about 133

initializing 142

SetTransObject function 139, 186
TriggerEvent function 215, 221
tutorial

database creation 36

files 19

setup 19

U

Update function 200

\'}

validation rule
overriding default message 71
specifying extended attribute 57

w

Watcom SQL  see database
WHERE clause 158
window
adding a menu 223
creating 74
default size and position 99
deleting a control 80
descendant 230
maximize attribute 97
menu testing 225
Open event 134, 185
Open function 90
PictureButton 77, 192
popup menu 98, 135, 185
resizable attribute 97
saving 87
title 96
Window painter
adding a menu 223
aligning controls 202



Window painter (continued)
DataWindow control 126, 176
DataWindow dialog box 130
Default to 3D option 75
deleting a control 80
duplicating controls 193
Inherit from Window dialog box 231
opening 74
opening and closing 88
PictureButton 77, 192
PictureButton dialog box 81, 232
PictureButton Style dialog box 79, 195
preview 180
Save Window dialog box 87, 234
Select DataWindow dialog box 129, 178
Select Picture dialog box 79, 194, 197
Select Window dialog box 74, 223, 230
spacing controls 202
Window Position dialog box 99
Window Style dialog box 97, 223, 233
Windows
Control Panel currency format 62
New Program Object dialog box 243
Program Manager 242
Windows directory, ODBC.INI file 37

255



	00967239.tif
	00967240.tif
	00967241.tif
	00967242.tif
	00967243.tif
	00967244.tif
	00967245.tif
	00967246.tif
	00967247.tif
	00967248.tif
	00967249.tif
	00967250.tif
	00967251.tif
	00967252.tif
	00967253.tif
	00967254.tif
	00967255.tif
	00967256.tif
	00967257.tif
	00967258.tif
	00967259.tif
	00967260.tif
	00967261.tif
	00967262.tif
	00967263.tif
	00967264.tif
	00967265.tif
	00967266.tif
	00967267.tif
	00967268.tif
	00967269.tif
	00967270.tif
	00967271.tif
	00967272.tif
	00967273.tif
	00967274.tif
	00967275.tif
	00967276.tif
	00967277.tif
	00967278.tif
	00967279.tif
	00967280.tif
	00967281.tif
	00967282.tif
	00967283.tif
	00967284.tif
	00967285.tif
	00967286.tif
	00967287.tif
	00967288.tif
	00967289.tif
	00967290.tif
	00967291.tif
	00967292.tif
	00967293.tif
	00967294.tif
	00967295.tif
	00967296.tif
	00967297.tif
	00967298.tif
	00967299.tif
	00967300.tif
	00967301.tif
	00967302.tif
	00967303.tif
	00967304.tif
	00967305.tif
	00967306.tif
	00967307.tif
	00967308.tif
	00967309.tif
	00967310.tif
	00967311.tif
	00967312.tif
	00967313.tif
	00967314.tif
	00967315.tif
	00967316.tif
	00967317.tif
	00967318.tif
	00967319.tif
	00967320.tif
	00967321.tif
	00967322.tif
	00967323.tif
	00967324.tif
	00967325.tif
	00967326.tif
	00967327.tif
	00967328.tif
	00967329.tif
	00967330.tif
	00967331.tif
	00967332.tif
	00967333.tif
	00967334.tif
	00967335.tif
	00967336.tif
	00967337.tif
	00967338.tif
	00967339.tif
	00967340.tif
	00967341.tif
	00967342.tif
	00967343.tif
	00967344.tif
	00967345.tif
	00967346.tif
	00967347.tif
	00967348.tif
	00967349.tif
	00967350.tif
	00967351.tif
	00967352.tif
	00967353.tif
	00967354.tif
	00967355.tif
	00967356.tif
	00967357.tif
	00967358.tif
	00967359.tif
	00967360.tif
	00967361.tif
	00967362.tif
	00967363.tif
	00967364.tif
	00967365.tif
	00967366.tif
	00967367.tif
	00967368.tif
	00967369.tif
	00967370.tif
	00967371.tif
	00967372.tif
	00967373.tif
	00967374.tif
	00967375.tif
	00967376.tif
	00967377.tif
	00967378.tif
	00967379.tif
	00967380.tif
	00967381.tif
	00967382.tif
	00967383.tif
	00967384.tif
	00967385.tif
	00967386.tif
	00967387.tif
	00967388.tif
	00967389.tif
	00967390.tif
	00967391.tif
	00967392.tif
	00967393.tif
	00967394.tif
	00967395.tif
	00967396.tif
	00967397.tif
	00967398.tif
	00967399.tif
	00967400.tif
	00967401.tif
	00967402.tif
	00967403.tif
	00967404.tif
	00967405.tif
	00967406.tif
	00967407.tif
	00967408.tif
	00967409.tif
	00967410.tif
	00967411.tif
	00967412.tif
	00967413.tif
	00967414.tif
	00967415.tif
	00967416.tif
	00967417.tif
	00967418.tif
	00967419.tif
	00967420.tif
	00967421.tif
	00967422.tif
	00967423.tif
	00967424.tif
	00967425.tif
	00967426.tif
	00967427.tif
	00967428.tif
	00967429.tif
	00967430.tif
	00967431.tif
	00967432.tif
	00967433.tif
	00967434.tif
	00967435.tif
	00967436.tif
	00967437.tif
	00967438.tif
	00967439.tif
	00967440.tif
	00967441.tif
	00967442.tif
	00967443.tif
	00967444.tif
	00967445.tif
	00967446.tif
	00967447.tif
	00967448.tif
	00967449.tif
	00967450.tif
	00967451.tif
	00967452.tif
	00967453.tif
	00967454.tif
	00967455.tif
	00967456.tif
	00967457.tif
	00967458.tif
	00967459.tif
	00967460.tif
	00967461.tif
	00967462.tif
	00967463.tif
	00967464.tif
	00967465.tif
	00967466.tif
	00967467.tif
	00967468.tif
	00967469.tif
	00967470.tif
	00967471.tif
	00967472.tif
	00967473.tif
	00967474.tif
	00967475.tif
	00967476.tif
	00967477.tif
	00967478.tif
	00967479.tif
	00967480.tif
	00967481.tif
	00967482.tif
	00967483.tif
	00967484.tif
	00967485.tif
	00967486.tif
	00967487.tif
	00967488.tif
	00967489.tif
	00967490.tif
	00967491.tif
	00967492.tif
	00967493.tif
	00967494.tif
	00967495.tif
	00967496.tif
	00967497.tif
	00967498.tif
	00967499.tif
	00967500.tif
	00967501.tif
	00967502.tif
	00967503.tif
	00967504.tif
	00967505.tif

